0
$\begingroup$

I am trying to add an Octopi to my Ender 3 V2 but the Pi cannot detect the printer at all. So I try to connect to Windows and same result. The display turns on and is functional, but when checking device manager there is nothing to be found. I am using the 2.0.7 Marlin firmware on the machine and have tried about 6 different USB cables/other ports.

$\endgroup$
7
  • $\begingroup$ Did you install the CH340/1 device drivers on Windows? Note that not all ports may work, my previous computer only allowed connection over the usb ports at the back. $\endgroup$
    – 0scar
    Commented Oct 8, 2020 at 21:47
  • $\begingroup$ I just tried all the ports on the back one by one with device manager open and there was no change. I have the CH340 drivers installed, but not the FTDI drivers since device manager doesn't pick it up in the first place. $\endgroup$
    – recalm
    Commented Oct 9, 2020 at 0:15
  • $\begingroup$ What board is it exactly? Uploading the firmware worked fine? $\endgroup$
    – towe
    Commented Oct 9, 2020 at 8:01
  • $\begingroup$ Is the printer switched on? $\endgroup$ Commented Oct 9, 2020 at 12:36
  • $\begingroup$ I have the 4.2.2 board, no issues with changing firmwares. I've tried with the power supply on and off, neither make a difference. $\endgroup$
    – recalm
    Commented Oct 9, 2020 at 17:05

1 Answer 1

2
$\begingroup$

After trying about 10 USB cables I finally found one that would work with the Ender and Pi. Specifically, it was my Logitech MX Ergo USB cable.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .