0
$\begingroup$

I just assembled an FLSUN QQ-S pro printer and successfully printed two models from the supplied SD card. Everything works fine. However, I tried slicing my own model using PrusaSlicer and although the print head moves, the extruder motor does nothing. What could be the issue? Do I need to modify the G-code commands?

$\endgroup$
5
  • $\begingroup$ Is this a single-head (max) printer? Does your gcode have a T# argument, to direct extrusion commands to a particular head? $\endgroup$
    – Davo
    Oct 17 '20 at 18:22
  • $\begingroup$ It is a single head printer. $\endgroup$
    – mr_js
    Oct 17 '20 at 20:57
  • $\begingroup$ Do you see extruder movement G-codes in the file? e.g. lines with G1 X... Y... E... $\endgroup$
    – 0scar
    Oct 18 '20 at 10:47
  • $\begingroup$ I solved the problem. The initialization code generated by the slicer wouldn't work with my machine. I replaced it with the init code from one of the test files. $\endgroup$
    – mr_js
    Oct 19 '20 at 7:34
  • $\begingroup$ Despite being solved, I want to note, that this was probaly due to using wrong extruder positioning. Prusa printers use relative positioning, whereas othe printers may use absolute positioning. I do not see any pros or cons for one or the other. Both the printer and the slicer can be configured to use either of them. In your case, it was probably that the printer was expecting absolute coordinates and the slicer was feeding relative coordinates resulting in no or very little movement. The configuration ussually happens at the start of the gcode by giving commands: M82 (abs) and M83 (rel). $\endgroup$ Oct 19 '20 at 8:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.