2
$\begingroup$

For my Ender 3 Pro I bought this touch sensor set Chinese clone BLTouch set and changed the printer's firmware to the latest TH3D firmware (first I tried with Creality's original BLTouch firmware but after 4 hours, I never managed to set a correct Z offset, I believe there is a bug or this BLTouch clone isn't compatible with Creality firmware).

After installing TH3D, found the right Z offset, when I print items like this one which stays at the center everything just perfect it sticks well, no strings, strong lines.

But if I try to print something like this which is using almost all the printing table from corner to corner (I need to rotate the print 45° to fit onto the build platform), it's good on center or near to center but not sticking on the corners and first lines are sticking to nozzle (because at the far corners, the nozzle is too far or too close) and makes a mess.

I powered off the printer and adjusted the good old way (with a paper) and re-setted the Z offset accordingly but the result is the same.

According to my research some peoples advised you need to add G29 after G28 to your G-code to get proper solution, I added the code in Cura. When I try adding G29, the printer starts leveling after starting printing, but the "not sticking problem at the corners" still continues.

I tried with both magnetic bed & glass bed, but nothing helped. I was using 200 °C for the nozzle and 60nbsp;°C for the bed, printing speed is 50nbsp;mm/s with Standart quality 0.2nbsp;mm, retraction enabled, mostly using 10nbsp;% infill on my models.

I thougt maybe filament causes this problem, changed filament to another roll but not helped, I also have an Ender 3 V2 (no BLTouch) and tried same model, same filament, same settings on V2 printed perfectly.

This is how my bed looks like according to OctoPrint bed visualizer plugin;

enter image description here

I've watched many tutorial videos and some said you need to adjust your bed with spirit level to make sure it's flat, I even did that and it is just perfectly flat.

I've installed the BLTouch clone 1 week ago and I'm struggling with this problem since then, I believe I'm missing something very obvious or making a realy simple mistake because many people use touch sensors and they are all happy with auto bed leveling.

$\endgroup$
2
$\begingroup$

Following Nathan's answer, I've solved my problem with Nathan's suggestions and the method in this video.

What I did?

  1. Flashed Creality's original BLTouch firmware to printer
  2. Heated up bed to 60 °C
  3. Leveled bed the old fashion way first, but with slight resistance (you don't have to level perfectly)
  4. Followed the youtube method to find proper Z offset
  5. Opened Cura, Settings->Printer->Manage Printers: and added G29; ABL after G28 enter image description here

Voilâ, now your printer prints perfectly! Enjoying the relieving after 1 week of struggling.

$\endgroup$
1
$\begingroup$

I would suggest you read this, even tho it's a different mainboard it may help.

Next to that you should level the bed the old fashion way first with a paper on the 4 outer corners, it is essential that you do this because ABL can only compensate so much when printing. After that set the Z-offset using a paper and run some bed adhesion test prints and use babysteps.

Level and probe your bed with it being heated up to 60 °C for PLA and 80 °C for PETG, the thermal expansion of the bed can easily mess up the probe data you already have!

Also make sure your ABL functions as Z-endstop; it solved all the issues for me.


If you ever want to upgrade your mainboard for some reason I can highly recommend the SKR mini E3 V2 it has great support for additional sensors.

$\endgroup$
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.