I first want to say thank you for taking the time to read this. I've been trying to print out some parts for another project of mine. These parts use up around 70% of the bed so they are fairly large, unlike the smaller trinkets and things I normally print.

However, I have yet been able to print one of these larger parts without any layer shifting. The part I've been trying to print is a lid to the bottom of a case. It's square, with rounded corners, about 160mm x 160mm.

It will print the first layer without shifting most of the time. However, upon starting the second layer it will almost have at least one layer shift. I have tried a number of things to remedy this, which I will list further down this post.

The layer shifting seems to be unrelated to jerk, acceleration, bed shifting, and z offset at the very least. There is an audible clunk sound that can be heard when it does this. In the image I've linked, you can see the correct path of the print head through the green arrows. However, upon a layer shift, it follows the path of the red arrows. It never shifts during a direction change, only when it is following a straight path. It's almost as if one of the motors gives up for a second. I am aware the print is under extruded, this is one of my trials hoping it was merely the nozzle clipping against the print.

enter image description here

Allow me to share with you my setup:

  • I have an Ender 3 V2, with the stock mainboard, stock glass bed, and stock hotend.

  • I've replaced the extruder assembly with an all-metal one from Creality.

  • I have the stiffer bed springs. As well as the better PTFE tube fittings and Capricorn tubes.

  • I've put together a cooling pack on Thingiverse. https://www.thingiverse.com/thing:4644985 The mainboard and hotend fans were replaced with Noctua performance fans that I'll talk more about later.

  • The hotend assembly is a hero me gen 5 with dual 4010 fans and a BLTouch.

  • I'm using Smith3D's 5x5 high-speed firmware (Previously the 4x4 high speed).

Now let me share my tried solutions.

  • I firstly, disassembled the printer, checking all belt teeth and motor gears (which are pressed onto their shafts without a grub screw). Afterward, I readjusted all eccentric nuts to get the perfect amount of tension while maintaining smooth operation on both X and Y axes. I've used brake cleaner and dish soap to remove the grease on the Z-axis lead screw and replaced it with WD-40 dry lubricant.

  • Continuing, I've releveled the bed and checked all axis operation to ensure it was smooth and without any bumps, hitches, or anything of the sort.

  1. I tightened all the frame screws, hotend screws, fan screws, grub screws. Nothing moves even a millimeter.

  2. The belts were tensioned so that they can be strummed like a guitar string when I move either the hotend or bed to its end stop.

  3. I checked my aftermarket fans to ensure they are working. The mainboard and hotend fan run nonstop at their optimal 12V. The PSU fan turns on and off as it needs to cool the PSU...

  4. The cables are nicely managed in the mainboard compartment and I'm sure that the larger fans provide it plenty of airflow. Not to mention the printer was raised by the use of squash-ball feet.

  5. I have slowed my print speed from 75mm/s to 60mm/s with this print. This means a 30mm/s inner/outer wall along with 60mm/s infill speed and 150mm/s travel speed. Acceleration and jerk are at their defaults: 500mm/s^2 and 10mm/s.

  6. I've adjusted my Z offset so that it slightly under extrudes to prevent the filament from bunching up.

  7. I've calibrated my e steps.

  8. I've formatted the SD card and changed my firmware from Smith 3D's 4x4 high speed to 5x5 high speed.

  9. I've updated Cura to the latest version 4.8 and ensured my hero me home offset is correct.

  10. I've tried moving the model to different corners in Cura and ensured the software's jerk and acceleration control are disabled.

  11. I've checked the bed movement with its clips, it doesn't move easily and both clips have very good tension.

  12. I've checked the stepper driver voltages (I did not change them). E: 1.34V Z: 1.16V Y: 0.99V X: 1.15V.

  13. I have Z hop enabled with a 0.2mm hop, no issues or noises when it moves across the print.

  14. I've purchased a filament dry-box from SUNLU along with a new spool of SUNLU black filament. The dry box has Capricorn PTFE tubing that leads the filament straight into the extruder. There is very little friction inside the tube.

  15. I've slightly tightened the tension on the extruder although I didn't have problems with it skipping.

Again, I'd like to reiterate, nothing is loose on this printer, it doesn't skip when it rapidly changes directions, only when following either a straight or diagonal line. The printer movement is very smooth and near-silent with all of my modifications. It's frustrating to me that I can't solve this problem. I feel like the printer has a mind of its own. I have begun to suspect either the mainboard or something else hardware related is amiss. However, I have chosen not to mess with it until posting this. If you've read through this, I thank you for your patience and time reading it.

Any advice or possible causes to this problem are welcomed. I am at a complete loss and am desperate for a solution.


3 Answers 3


You mentioned a noticeable 'clunk' when it shifts, are you sure it isn't a physical obstruction? You said you checked that all axis run smoothly but are you sure you checked the full extents of the printable area?

Watch carefully when the issue happens, are any of the cables getting snagged on the machine or surrounding workspace? Check under the bed in particular, I've noticed on my Ender 3 V2 the bed will sometimes bump into part of the base if the leveling screws are tightened too far.

  • $\begingroup$ I am 99.9% certain there isn't a physical obstruction. When I reassembled the printer I made sure there were none. The bed has no wobble, it's rock-solid, but still easy to move by hand. The X-axis gantry is perfectly level and the hotend assembly glides along the rails with ease. There is some slight tension as it reaches the end due to it stretching out the wires, but nothing that the stepper motor can't overcome. The screws don't come into contact with anything that I can see... The nozzle doesn't make any noise at all while laying down filament or traveling over the print. $\endgroup$
    – Jaymerx
    Commented Jan 11, 2021 at 0:33
  • $\begingroup$ I have cable chains that keep them up and away from the print. The belts are snug and the teeth don't touch anything besides the gears on the motor shafts. The Z axis (while having slight wobble) doesn't snag or bind on anything. The layer shifts only persist in the X Y direction. Also, I feel like if there were a physical obstruction, it would have a persistent shift that happens in the same location. However, the layer shifts vary in location and intensity as it prints. $\endgroup$
    – Jaymerx
    Commented Jan 11, 2021 at 0:37
  • $\begingroup$ Good points. I just noticed from your image and the helpful arrows that it seemed the y-axis missed a step, which reminded me of some of the collision issues I noticed on mine. From your other tests, does it seem to always fail the same way - where the y-axis seems to miss a step? I wonder if it could be related to that lower voltage on your Y driver but that is beyond my knowledge level. $\endgroup$ Commented Jan 11, 2021 at 0:49
  • $\begingroup$ Funny you mention that... I found a youtube video where they (Creality Rep) are trying to fix a non functioning Z axis, but they probe all the drivers to check voltages. Mine were very similar. youtube.com/watch?v=erbyJCQDOy8 @ 3:00 Either both of our printers are malfunctioning or I'm just unlucky... $\endgroup$
    – Jaymerx
    Commented Jan 11, 2021 at 1:05


Unscrewing the mainboard enclosure and tilting it to allow better airflow like in the picture shown below. This is the same issue as many others.

enter image description here



I appreciate the assistance.


Not sure if you're still actively working on this but my setup mirrors yours almost perfectly, I added an all metal extruder, Micro Swiss hotend, a BLTouch, yellow bed springs and Capricorn tube and got great results but needed more cooling so I changed to the Hero Me Gen 5 using 2 5015 blowers and a Noctua 40x20 fan with a buck converter set to 12 V and noticed I had shifting so I printed 35 mm standoffs and wired another Noctua fan, 80x25. It helped reduce shifting but still not perfect and I as well has combed through every possible issue.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .