0
$\begingroup$

I have a Xvico X1 printer which I had previously installed an SKR 1.3 on running Marlin, which was functioning normally.

For Christmas I got a BLTouch, a heated bed and a Raspberry Pi for it, so I also installed a new 24 volt Meanwell PSU to power it.

I believe I have correctly installed and updated the firmware for the BLTouch and the heated bed. However, I am having confusing results for my hotend. I successfully ran a PID, though the values seemed suspiciously high (Kp 17.87, Ki 1.24, Kd 64.41).

So my next step was to run a test print. The temperature for the print was set for 200 °C, but after the bed heated, the hotend quickly got to 200 °C and continued to heat until it hit the thermal runaway limit and shut off. I repeated this 3 times, then decided to call it a night and unplugged the machine.

The next time I tried it I had a different result, instead of heating quickly, when the print was started the temperature dropped from 22 °C (room temp) to 8 °C (error?). I have seen that similar errors are sometimes caused by incorrect heater cartridge, but I changed the 12 V cartridge I had installed to a 24 V cartridge when I changed the PSU. I don't really think it's a hardware issue, but I also feel like the firmware is correct so any help would be greatly appreciated.

I have attached a picture which shows an initial drop (in response to a PLA preheat command), then a spike in temperature (hotend set to 200 °C, I had to manually stop it) then I ran a PID autotune, which completed normally, and received the values listed previously.

Graph - Temperature vs. Time

$\endgroup$
2
  • 2
    $\begingroup$ Are you sure it is a 24 V cartridge? This awfully looks like a large overshoot due to a wrong cartridge (I've had this once where my cartridges got mixed up in my spares toolboxes). Please measure the resistance of the heater element. $\endgroup$ – 0scar Jan 11 at 22:52
  • $\begingroup$ I did not think this was the case, the 12 V has a dimple at the end while the 24 volt doesn't. I checked anyway and sure enough the resistance was 14.7, so I'm still at a loss $\endgroup$ – westph21 Jan 13 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.