0
$\begingroup$

I have an Ender 3 v2, but it needs a -1.80 mm offset (because the nozzle height is different from homing and printing). I was recommended OctoPrint but can't seem to figure out how to set a Z offset

I've tried my slicer, but it won't go further than -0.35 mm

I've tried both M851 and G1 Z-1.8 and then G92 Z0, but neither of them work

I've tried saving an offset on the actual printer, but it only has live-adjustment during a print. I can't 'set' it as such.

I've tried the following G-code as well:

M851 Z0
G28
G1 X110 Y 110
M211 S0
M851 Z-1.8
M500

But nothing works, any suggestions would be greatly appreciated.

$\endgroup$
1
  • 1
    $\begingroup$ There are multiple ways to define the Z offset. Please look into the answers of Cura: set z-offset. Although you can add code to OctoPrint to set an offset, it is not the place to do that. I wonder why you need a -1.8 mm offset in the first place... Do you use a BLTouch or something like that? Please edit the question to include this. Note that M851 needs to be set once after you saved settings with M500. Are you using an SKR board that doesn't allow storing of settings (has been an issue in earlier versions of Marlin). $\endgroup$ – 0scar Jan 12 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.