8
$\begingroup$

The $200 Monoprice Select is inexpensive but also cheap, so experiences I've seen appear to involve lots of repairs. In spite of that, I've bought one, as I'm able to fix things (sometimes) and the first few prints have been pretty good quality. ( I hear this unit is also sold as a Wanhao I3 )

First repair was that the control knob only worked in one direction (fix: bad encoder-PCB connector cable. Repaired)

Upon trying to change filament, the feeder fitting that enters the hot-end heatsink has come off. This fitting has a thread, but strangely the heatsink does not seem to. As I tried to unscrew it, to check for a feed blockage, it just let go, and I see no part that could have held it in place. (See pic)

I'm guessing that it was just epoxy-glued to the heatsink. Sounds kludgy but possible. Does anyone know?

Can any other owner verify how theirs is attached?

[ Also, posted as a caution for someone else who tries to do this. :( ]

Thanks in advance. broken hotend filament feeder

$\endgroup$
6
$\begingroup$

Solution - there is a set-screw and a square nut in that T-slot which holds the feeder fitting in place on the heat sink.

One may well think (as I did) that the fitting is threaded into the heatsink, since it does have a big hex-head for a wrench. A small turn an the set screw lets go, the nut sliding down the slot with it. Thus when you inspect it, you don't realize they are involved 'cuz they aren't around.

Simply slide back up and you're in business.

Mystery solved - thx to Mark on Twitter. :)

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ Do you have a link to the twitter post? $\endgroup$ – Greenonline Aug 19 '19 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.