2
$\begingroup$

I use Slic3r to create G-codes for my Labists ET4 printer. Usually, no problem.

Now, as soon as I tried to start a print, the nozzle head went down as usual, but this time it went a bit lower than 0 and the machine made angry noises for less than a second.

It went back up again and heated the bed and the nozzle, only to go back down too strongly with angry noises again. Even left a little pokey hole on the bed.

I got scared and turned the machine's switch off and manually raised the Z axis with ease.

Never had this problem before and now I'm afraid to turn on my machine.

I've had the following setup for G-codes prior to today's incident and it had worked just fine:

G28 ; Home extruder
G1 Z15 F[travel_speed]
M106 S[max_fan_speed]; Turn on fan
G90 ; Absolute positioning
M82 ; Extruder in absolute mode
; Activate all used extruder
M104 T0 S[first_layer_temperature]
M190 S[bed_temperature]
G92 E0 ; Reset extruder position
; Wait for all used extruders to reach temperature
M109 T0 S[first_layer_temperature]

After this, I did try the auto levelling, however it still tried to plow into the bed, albeit not as angrily.

Here's other things to potentially consider:

  • I haven't used the machine 10 days.
  • It's been chilly in the room where the machine is.

So here's my questions:

  • "What could cause a 3D printer to have an incorrect impression of Z-axis=0 even in absolute position mode?"
  • "What can I do to fix it?"
$\endgroup$
6
  • 1
    $\begingroup$ Please do the automatic levelling with the sensor attached, you will not damage the bed then. When you tried, please update the question that you tried it and it doesn't work, or ,if it does work post an answer and accept it after 48 hours! $\endgroup$ – 0scar Jan 24 at 11:42
  • $\begingroup$ Hi @0scar! I added info. Unfortunately the auto levelling still had the nozzle attempt to burrow into the bed. Not sure what my next step should be :/ $\endgroup$ – B7th Jan 26 at 3:17
  • 1
    $\begingroup$ That is quite strange, the sensor should have established the level seen from the top. $\endgroup$ – 0scar Jan 26 at 13:22
  • 1
    $\begingroup$ So it probably is a build-up of molten carbonized filament, yes, that makes that the "nozzle + gunk" hits the bed after leveling. Heat up the hotend and remove all the additional material on the nozzle. $\endgroup$ – 0scar Jan 27 at 8:18
  • 1
    $\begingroup$ This is not an Anet ET4 then! I've updated the question for you! $\endgroup$ – 0scar Jan 27 at 10:33
2
$\begingroup$

Dirt. It was dirt. Most likely.

enter image description here

Apparently the machine establishes bed level with a sensor, and I might be wrong, but I think the ET4 monitors capacitance as a means to notice how far the nozzle is from the bed.

After all else failed I looked at the nozzle closely and noticed that the whole thing looked fuzzy. Looks like soot (from where though!?) had settled on the machine's sensitive components and de facto blind-folded its sensor.

A wipe and a levelling later, all was back to normal. Yay!

$\endgroup$
4
  • 1
    $\begingroup$ metal, carbon, or filament dust deposits can drastically alter the capacity $\endgroup$ – Trish Jan 27 at 8:20
  • 1
    $\begingroup$ The strange thing is is that the Anet ET4 uses an external sensor based on nozzle pressure that you connect during the levelling phase to the loose connector hanging next to the hotend. It doesn't use a inductive or capacitive sensor, it uses this sensor. $\endgroup$ – 0scar Jan 27 at 8:37
  • $\begingroup$ @0scar Is it possible that there are two different ET4? Cause mine is from Labists and I don't recognize this probe? $\endgroup$ – B7th Jan 27 at 8:53
  • 1
    $\begingroup$ I've changed the question to the correct printer. There are 2 ET4 printers! Yours does use an inductive sensor! $\endgroup$ – 0scar Jan 27 at 10:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.