I was printing an object and it started to drag so I stopped it.

Went to move the Z-axis up so I could clear the bed and Z-axis would not budge. I switched the printer off and manually turned the motors to get the Z up. Cleared the bed, switched on and homed the printer. When it came to home the Z, BLTouch deployed and then nothing. Motors will not turn.

Things I tried:

  • Recompiled the firmware (Marlin 2.0.x)
  • Different motors - Motors were free from the printer, just resting on a desk so I know it's not binding or anything.
  • Swapped stepper driver with a known working one.

Info about the printer:

  • CR10s
  • SKR1.4 Turbo board
  • TMC2208 Steppers
  • BLTouch
  • Octopi to control the printer.

Output of M122 for the Z:

Recv:       Z  
Recv: Address  
Recv: Enabled       false  
Recv: Set current   1000  
Recv: RMS current   994  
Recv: MAX current   1402  
Recv: Run current   17/31  
Recv: Hold current  8/31  
Recv: CS actual 8/31  
Recv: PWM scale  
Recv: vsense        0=.325  
Recv: stealthChop   true  
Recv: msteps        16  
Recv: tstep     max  
Recv: PWM thresh.   0  
Recv: [mm/s]        -  
Recv: OT prewarn    false  
Recv: triggered  
Recv:  OTP      false  
Recv: pwm scale sum 10  
Recv: pwm scale auto    0  
Recv: pwm offset auto   36  
Recv: pwm grad auto 14  
Recv: off time  4  
Recv: blank time    24  
Recv: hysteresis  
Recv:  -end     2  
Recv:  -start       1  
Recv: Stallguard thrs  
Recv: uStep count   40  
Recv: sg_result  
Recv: stst  
Recv: olb  
Recv: ola  
Recv: s2gb  
Recv: s2ga  
Recv: otpw  
Recv: to  
Recv: 157C  
Recv: 150C  
Recv: 143C  
Recv: 120C  
Recv: s2vsa  
Recv: s2vsb  
Recv: Driver registers:  
Recv:       Z   0xC0:08:00:00  
Recv: Testing Z connection... OK  
  • $\begingroup$ First I suspected this could be faulty Z motor cable (broken wire, etc.). The G-Code M122 is for communication with the driver board. There can be almost no feedback from motor itself (there are just 2 pairs of coil wires) ...almost, because we can see Testing Z connection... OK. But anyway, to be on safe side, did you doublecheck with multimeter that Z motor cable is properly conducting? (There is only one Z motor in this printer, isn't it?) $\endgroup$
    – octopus8
    Jan 24 at 19:35
  • $\begingroup$ Please add the update as an answer, answers should not be in questions. You can accept the answer after 48 hours. Thanks! $\endgroup$
    – 0scar
    Jan 25 at 12:13
  • $\begingroup$ Sincere apologies for your question being temporarily closed - it was an admin error. Please add the "Update" as an Answer, even though it wasn't quite resolved, because putting the solution inside the question breaks the Q&A mechanism of the site. Many thanks. $\endgroup$
    – Greenonline
    Feb 1 at 4:13
  • $\begingroup$ For "suddenly have this issue" the only explanation I have is that of Z steps/mm set to 0, and could happen unintentionally (from LCD or with M92). (Unless someone recompiled firmware with changed settings, then it's suddenly no more.) So @Gaz83, could I propose to accept my answer and have this question closed already? $\endgroup$
    – octopus8
    Feb 2 at 4:03

It could be caused by software or configuration issue.

Possibility 1: just worked after re-installation of Marlin

You could have Z steps/mm set to 0 in EEPROM, and did not notice that fact. It is possible to fix this unconsciously with Marlin software reinstallation, following the upgrade procedure which included reset of EEPROM settings - like "Step 4: Finishing touches" described in community wiki's guide for Updating Marlin Firmware. This is described in more details in another post No stepper motor movement on Ender 3 Pro.

Possibility 2: Marlin configuration is not correct

When you recompiled Marlin, did you use already proven configuration for Marlin? When saying "Motors will not turn" you mean only Z? Are your other motors are still functional now after Marlin was deployed?

Among other Marlin settings, you may want to check that this line is disabled in Configuration_adv.h:

   * Software enable
   * Use for drivers that do not use a dedicated enable pin, but rather handle the same
   * function through a communication line such as SPI or UART.

(I took this advice from No Motor Power With TMC2209 on RepRap forum.)

  • $\begingroup$ Yes I used the copy I already had, just recompiled. Yes X and Y worked fine $\endgroup$
    – Gaz83
    Jan 25 at 6:21
  • $\begingroup$ Thank you for the feedback. And it is good to hear that you have resolved your issue. If you would like to find a root cause - then if reinstallation od software helped after you "deleted your Marlin" and "a fresh downloaded copy" worked better, then maybe there was a difference in (1) configuration or (2) the code (at least version of Marlin). If there are no justifiable differences, I have a very good theory - so I will improve my answer. $\endgroup$
    – octopus8
    Jan 25 at 20:14
  • 1
    $\begingroup$ The only problem with possibility 1 was that the printer was running. It had homed and started printing. I then Paused using octopi (pause button, not in terminal) and then used the controls to try and move Z up and that's when it stops. So there was no M92, or any other commands, used. I appreciate the support. $\endgroup$
    – Gaz83
    Feb 2 at 8:10
  • $\begingroup$ Compilation errors happen. $\endgroup$
    – Trish
    Feb 2 at 8:42

Issue seems to be resolved. I deleted my Marlin copy, downloaded a fresh copy and I started again.

What worries me is how a working copy and a working printer can suddenly have this issue. Feel like this issue could come back as I never found the root cause.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.