I have an old Anycubic i3 Mega printer which started having issues keeping the hotend-temperature. The peak at the start of the diagram was when I was touching the cable on top of the hotend: enter image description here

It also sometimes disconnects completely with a MINTEMP-Error

So it is fair to assume it might be an issue with the cable/plug to the hotend.

My problem is that I cannot find that cable anywhere on the Anycubic spare parts site. Is this maybe a "standard" cable that I can get anywhere else?

enter image description here

  • $\begingroup$ The end itself looks like it could be a Molex connector. A picture of it unplugged may help identify it. $\endgroup$
    – agarza
    Jan 27, 2021 at 13:53

1 Answer 1


The plastic looks ok. If you get the tools and pins to work on the connector, you could replace problem pins. Many of us build our own cables. If we verify the connector is Molex, you might need calipers to measure dimensions to get the correct size. You won't need expensive ones. I've seen digital calipers from \$10 to \$20.

Have you already verified your sensor and heater aren't an issue? Maybe you've tried a new hot end, or a new heater block with a new heater and sensor.

You can visually inspect the pins on the connector to see if they have a loose connection. See the solution at Proper hotend heater for Reprap x400 Pro V3

What is strange from you graph, you seem to be loosing connection to both thermistors. Do the thermistors to the bed and hot end share one common connection, so that one pin could affect both?

If you haven't already tried it, one quick fix to try is unplugging the cables and plug them in again with the printer off of course.

  • $\begingroup$ I am quite sure it is the cable/plug. I only have to bend to cable a little bit to force the temperature-graph to go wild $\endgroup$
    – Ole Albers
    Jan 28, 2021 at 14:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .