1
$\begingroup$

I've updated to Marlin 2.0.7 when I set up a BLTouch and now it seems the temperature does not match the display. Before the update, I was printing with PLA filament at 205 °C and bed at 60 °C without issue. After the update, my prints are full of stringing, so I decided to lower the temperature until 180° and now it's fine. (everything above 185 °C is stringing) I've tried tuning PID but it wasn't better. So I assume my printer sees 205 °C but the real nozzle temp is higher.

$\endgroup$
5
  • $\begingroup$ You might want to get a not for humans infrared thermometer to measure temperatures. Note: the forehead thermometers have fudge factors to approximate body temperature. $\endgroup$ – Perry Webb Jan 27 at 16:12
  • $\begingroup$ I added an answer for case if this is just incorrect thermistor types set in Marlin. Use this guide if you forgot to reconfigure it following configuration of previous Marlin version. $\endgroup$ – octopus8 Jan 27 at 23:54
  • $\begingroup$ Interesting case study: Ender 3 displaying wrong temperatures for hotend and bed. $\endgroup$ – octopus8 Jan 28 at 23:59
  • $\begingroup$ @Nosfé, in my answer I suggested that your issue is related to incorrect settings for thermistors in firmware, or faulty thermistor, not to the BLTouch. Could you test if your temperature issue is going away, when you disconnect BLTouch and return to previous firmware settings? so confirm this way, that it is somehow related to BLTouch? $\endgroup$ – octopus8 Feb 1 at 7:17
  • $\begingroup$ I supplemented my answer for faulty thermistor verification, which was discussend in comments below it. If this is the case (according to your test with swapping boards), then apply the new piece of thermistor, accept the answer and have a happy printing! $\endgroup$ – octopus8 Feb 1 at 7:27
0
$\begingroup$

When you have updated to Marlin, you were supposed to configure it carefully. This is maybe laborious and sometimes difficult procedure, but very important. Basic guidelines are described in Configuring Marlin official guide.

I assume that you obviously did it, at least in some part to enable BLTouch. You should review the Thermal Settings section and update it with valid thermistors types for bed and hotend in Configuration.h:

#define TEMP_SENSOR_0 1
...
#define TEMP_SENSOR_BED 1

The list of available predefined settings (numerical identifiers) is just above these #define macros. The optimistic assumption is that you know that hardware details. Popular value is 1 for EPCOS 100k (older repraps) or NTC 3950 100k, but there are many examples of troubleshooting and advices on Internet. For more exotic temperature sensors you should set value 1000 and specify own details in Configuration_adv.h.

If all these settings are correct, then possibly your thermistor is faulty. There is always a chance of coincidence with some damage unrelated to last upgrades. You can follow these instructions to verify it.

$\endgroup$
10
  • $\begingroup$ Yes, I've edited configuration.h based on my board model (mks robin E3). I've tried to use 2.0.6 marlin from mks github but I've still the same issue. $\endgroup$ – Nosfé Jan 28 at 17:59
  • $\begingroup$ Hi, it is great that you don't give up and still look for solution. I am not sure why exactly you do try to downgrade Marlin - is this just a blind attempt, or if you have some extra data or infomation? What about thermistor details? Thermistor is not part of mainboard, but separate piece connected with 2 wires to the board. Do you know what thermistors are installed in your printer? What values are set for TEMP_SENSOR_0 and TEMP_SENSOR_BED in your Configuration.h? $\endgroup$ – octopus8 Jan 28 at 20:54
  • $\begingroup$ Hi, it was a blind attempt just to see if I missed some paramaters by editing files by myself! I have no idea of my thermistors, I've let default config for both : 1 : 100k thermistor - best choice for EPCOS 100k (4.7k pullup) I still have the creality original board, is there a way I can see what thermistor is set on it firmware? Thanks for helping :) $\endgroup$ – Nosfé Jan 28 at 22:00
  • $\begingroup$ No, as far as I knot there is still no possibility to export Marlin configuration (except for EEPROM contents). I tried to google for Ender 3 thermistors and checked few sites: everyone insists that 1 for both is the valid for default Ender 3 configuration. (Btw. I also found an old school G-Code M305, but I'm not sure if experimenting is safe.). I just noticed, that you did not mention anything about wrong bed temp. - is that one ok? Can you swap them for a test? --> see more details here $\endgroup$ – octopus8 Jan 29 at 0:28
  • $\begingroup$ One thing to check: if you can deploy the original firmware, backup current EEPROM values for future reference, downgrage, but not reset EEPROM until last step. Check the following: (1) look in LCD main menu for "About Printer" (disabled by default) with "Thermistors" submenu; (2) run G-Code commands M503 and M305 without any parameters (may return something in case there were custom thermistors); then reset to factory (firmware) defaults with M502 and check again M503 and M305. (Note: M305 won't work at all if there was no custom thermistor set in config). $\endgroup$ – octopus8 Jan 29 at 7:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.