1
$\begingroup$

I have been printing with no problems. I have finished the spool of filament and removed the remaining filament from the Bowden tube and hotend. Before loading the new spool of filament, I decided to level the bed using the installed BLTouch.

Probe grid 3 x 3. Centre point of the build plate, X:135, Y:130.

Homed the bed (G28). Leveled the bed (G29). The first four probe points worked as expected. When the printhead moved to the fifth probe point, the screen read that the printhead was in the expected position (X:130, Y:130). The printhead had only moved about 20 mm, meaning the true position was X:240, Y:130, I had checked this with a ruler. The sixth probe point also moved about 20 mm on the X-axis. The seventh point moved along the Y-axis correctly. The printhead tried to move correctly to the eighth point and promptly crashed into the side of the printer as it was trying to move 130 mm to the right. The screen had X:0 when in reality it was X:230.

I tried the ABL again. This time I aborted the ABL on the fifth probe point as the previous event had been repeated. Reported position, X:130, Y:130. The true position, X:240, Y:130. I then tried to home the bed (G28). The printhead moved a short distance to the left (<20 mm) on the X-axis, reported on the screen X:0, and started along the Y-axis. When it had reached Y:0 (true position) it then moved diagonally to where it thought would be the center of the bed, but would have crashed into the side of the printer frame if I had not cut the power.

After re-setting the board, I could home the board either by using G28 or via the screen. I could move the printhead along the X-axis freely, both through Pronterface and the printer screen. If I tried to home the printhead when X>140, it would only move a short distance to the left, set X:0 on the screen, and head down the Y-axis.

I have checked for loose connections and everything seems tight. The only difference from when I was last able to print is there is no filament loaded.

Anybody any ideas what is wrong?

Printer: Hypercube Evolution (CoreXY) Board: KFB2.0

$\endgroup$
6
  • $\begingroup$ Short moves sound to me like loosing steps: by aggressive speed/accelleration? or by faulty stepper driver (you could try to swap X and Y stepper drivers and check this way). What is your homing mechanics - if it is based on mechanical or optical endstop? How does it work for G28 X executed from each different corner or other positions? And what firmware do you use? $\endgroup$
    – octopus8
    Feb 5 at 5:09
  • $\begingroup$ Marlin 2.0.6.1. Endstops are all optical. X-Max endstop packed in a few weeks ago. It has been disconnected from the board and commented out of Marlin. Other endstops used are X-Min, Y-Min and Y-Max. Z-Min used for the BL Touch. Z-Max used to drive BL Touch Servo. I will have to try the stepper drivers and G28 X command. I did not realise that you could home individual axes. $\endgroup$ Feb 5 at 7:14
  • $\begingroup$ Swapped stepper drivers around. Problem remains. Swapped X and Y stepper drivers for some others I had lying around. Problem remains. G28 X produced some interesting results. Home printhead to centre of bed, enter G28 X, desired result. Move printhead to X:100, enter G28 X, printhead moves right approx 10mm, screen shows X:0. Enter G28 X again, same result. Repeat two more times, same result each time. Repeat, printhead jerks to the left, then the right, screen shows X:0. Continued... $\endgroup$ Feb 5 at 8:45
  • $\begingroup$ ...Continued Repeat, no movement or change in display. Move printhead to the right, G28 X, moves to the left and then the right, screen X:0. Move printhead to left half of bed X:-100(I had to turn off software endstops to do this) G28 X produced desired result. Repeat process, but with Y moved to Y:235. Same results except for next to last attempt where printer crashed and had to be reset. Repeat process with Y:35, same result. $\endgroup$ Feb 5 at 8:46
  • $\begingroup$ Could it be the issue with too tight wheels, similar to this one? $\endgroup$
    – octopus8
    Feb 7 at 2:42
1
$\begingroup$

After many hours tinkering, pulling things apart, testing them and re-assembling them, it turned out that the problem was a broken wire for the X_Min endstop. This has now been replaced and the problem is resolved.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.