2
$\begingroup$

Hello dear Community,

I am trying to print my first Box and I have a problem with the skin of the bottom layers. After finishing the slicing and while looking into the generated G-code I was wondering why Slic3r increases the E-parameter continuously when 90 % of the lines have the same length and the axis have the same speed. Logically as long as the length of the lines are equal and the speed of the axis is also fixed so the amount of extraction has to be in this case also fix but that is unfortunately not the case. Therefore as you can see in the Result photo, that the printer prints the skin layer at the beginning in the right way with the right amount of extruded material. At the end of the skin layer, it seemed very bad because of the huge amount of extruded material.

Some Infos about my Printer may be interesting for you : Nozzle diameter = 2.7 mm Type of Filament= granules Diameter of filament = 2.5 mm

Please let me know your suggestions and feedbacks.

GECODE Part1/Skin Layer GCODE Part2/Skin Layer

$\endgroup$
0
2
$\begingroup$

The value you see is the cumulative extrusion, in other words the E value in consecutive G-code commands reflect a position of the filament since you started that print.

It is normal that it continuously increases in "absolute" mode.

You should see, at the beginning of the G-code, also a M82 or G90 command, which means "absolute extrusion". And you should avoid having M83 or G91 later in G-code, which would change an interpretation of E values to "relative extrusion".

It is more accurate than relative extrusion (which is the mode you are thinking about).

From your print it looks like the printing bed is not properly tuned, probably too far.

Also, it is difficult to see properly, but it looks like you get bubbles in the second part of the print, which are the reason there is an increase of extrusion: hot air pushes too much filament out.

Maybe your granules are not properly dry. It is difficult to tell you more, pellet extruders are more difficult to tune than filament extruders.

$\endgroup$
4
  • $\begingroup$ Hallo FarO, Thank you for your fast answer. 1- "The value you see is the cumulative extrusion" Can I change the calculation way of E values in the slicer to another form, For Example, Steps/mm or Volume or any other form than cumulative form? 2-"You should see, at the beginning of the Gcode, also a M82 command". Yes, I have at the beginning. $\endgroup$ – Otto_Scho Feb 10 at 8:46
  • $\begingroup$ 3-"From your print it looks like the printing bed is not properly tuned" It is properly tuned but I took the printed layers out from my table and the table was still warm 60°. But I was in hurry and didn't want to wait till it will be cold. That was my mistake. 4-"Maybe your granules are not properly dry." I agree with you. Yes maybe it was not dry enough but for sure that is not the main reason because the E-Values in Gecode increased linearly. $\endgroup$ – Otto_Scho Feb 10 at 8:46
  • $\begingroup$ The reason for the increasing E values is because it provides the cumulative extrusion. You can change the slicer to "relative E values" somewhere, but the firmware does the conversion anyway: it will NOT solve the issue. The print is identical. Cumulative is actually more accurate. Of course the gcode will be easier to read for you, but it will not change the print. $\endgroup$ – FarO Feb 10 at 11:00
  • $\begingroup$ Dear FarO, Thank you for the information. TheWord CUMULATIVE let me understand the reason for my problem and I will change the way of thinking to solve it. Thanks again :-) $\endgroup$ – Otto_Scho Feb 10 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.