3
$\begingroup$

I replaced my CR-10 motherboard with no problems and ran fine for a few weeks, then decided to add a BLTouch. BLTouch was enabled from the config.h during compile.

I had heating issues at first but eventually figured out I had the thermistors plugs swapped on the motherboard. In the past, I never used start and stop G-codes because I only printed printer upgrades off of Thingiverse while learning to print. My prints weren't starting until I learned more about G-codes and added G29 and G29 to my Cura start codes.

I tried a piece that I've printed before because I knew it worked ok. I preheated the bed and nozzle first, then started the print. The G28 initiates and homes, then the G29 does the 9 point bed leveling, then just sits there and does nothing.

BLTouch behavior during the process

  • BLTouch moves to "home" from center, with probe up and red light
  • With the light still remaining red, BLTouch goes back to the center
  • The BLTouch light turns blue once at the center, and drops the probe and lowers until probe touches and the light turns red
  • Then raises again and the light turns blue, lowers again until probe touches bed then the light turns red again
  • The light stays red and raises Z axis a little - and stays at center, still red
  • The probe stays at center and red until reaching preheating temps
  • After selecting file the probe moves to 9/9 points, with probe raised and blue light (drops probe and lowers until touching and turns red, then raises and turns blue)
  • Once the last probe location is checked, BLTouch is still red and temperature settings from project file are set and heating starts
  • The setpoints of bed and nozzle are reached (successfully heated)
  • After heating, the setpoints switch to zero and temps start dropping towards the zero set point (cooldown) and never moves after that and shows status "Stopped"

Pronterface - manual attempts

I connected through Pronterface so I could see the exact details. When I run a G28, from Pronterface:

  • It goes to lower corner and is still red
  • Returns to the center, probe drops and turns blue
  • A few seconds later it drops until touching the bed and turns red
  • Raises up again and turns blue, then drops BLTouch again until it touches the bed and turns red
  • Then raises up again, but stays red this time
  • I get an error in Pronterface "Stop called because of BLTouch error - restart with M999".

After it levels 9/9 points1, Pronterface shows a BLTouch error, the printer display shows print stopped, and the bed and nozzle setpoints had changed to zero. They both had already started cooling. I kept the start code simple just enough to get the print going.

I have no idea what the BLTouch error is but just that it caused two temperature settings to go to zero. Any help would be great!


1 The 9/9 points I'm referring to is when I run G29 and my config has 3x3 grid option selected so the G29 probes 9 points total with the BLTouch.

$\endgroup$
3
  • 2
    $\begingroup$ Temperature is reset because printer (emergency) stops the print, I bet it is not correlated to the G29 procedure. Please describe behaviour of the BT light during and after the process. How did you enable BL-Touch? from LCD? $\endgroup$ – octopus8 Feb 14 at 19:12
  • $\begingroup$ @Greenonline Not sure how to close this but I managed to figure it out, decided to try moving the Z-axis wires from the BLTouch plug on the motherboard and plugged them into where the printers Z-axis wires plug in and that solved the problem. No more errors and the print continues now instead of shutting down after the G29 command. $\endgroup$ – rsadler Feb 20 at 17:53
  • $\begingroup$ It's great that you've found an answer. Please post that as an answer, and mark it as accepted (you may have to wait a few hours before you can accept it). This will then remove your question from the unanswered queue (which we need to keep as short as possible because we are a beta site). Thanks. $\endgroup$ – Greenonline Feb 20 at 21:59
0
$\begingroup$

I was wondering if it had something to do with my Z axis and BLTouch. When I unplugged the Z Axis on the printer the extruder wouldn't lower only raise so I plugged it back in and it moves in the right directions. The mother board I'm using is a SKR E3 Mini V2 and the BLTouch is 3.1 On that version motherboard the BLTouch plug has all 5 wires combined in one plug, where on other versions it has a three wire plug for the BLTouch and the wires for the Z axis from the BLTouch has a seperate two wire plug with it's own plug in spot, but I've read about instances where users had to plug those two wires into the motherboards default plug for the printers Z axis which is usually unplugged. I decided to depin the BLTouch Z axis wires from the 5 wire plug and depin the printers z axis two wires and repin that plug with the Z axis from the BLTouch and plug into the spot on the motherboard that is normally used by the printers wires, and that fixed the problem. Here's the link on Github that board manufacturer posted about the issue, https://github.com/bigtreetech/BIGTREETECH-SKR-mini-E3/tree/master/firmware/V2.0 and thankfully that was my exact problem.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.