I have a used Creality CR-10S and I have been using it for one day. I seem to be having problems with my Y-axis. Several times when I selected "Auto home", the bed only moved part of the distance it should have for the head to get to the bottom left corner. It is only the bed movement that has the problem; the head successfully goes to the extreme left each time.

This picture shows an instance when the bed only moved half as far as it should.

It does not always happen and when it does, it seems to usually go half as far as it should, but once the bed did not move back at all. I am having a similar problem on "Bed Auto Leveling". Once when it was supposed to go to the back left corner, the nozzle went past the bed by about 5mm. I tried to reposition it with "Move axis" but it thinks it is at 0.00 and it won't let me go negative. One way I can fix it is to "Disable steppers" and then move the bed by hand.

I have done two prints and in both cases there was no Y-axis drift during the print. After first print, "Auto home" only went half way but I was not paying attention to other details. After the second print the machine was off and I moved the bed by hand in response to @octopus8. Then I turned it on and selected "Auto home". The head descended and moved all the way to the left but the Y-axis did not move at all.

When I move the bed by hand through its entire range, either with the machine off or after choosing "Disable steppers", it is pretty smooth. It has some resistance to movement, about the same as the X-axis resistance. I can feel very small "steps" if I move it very slowly. These are both consistent throughout its entire range. There are no individual spots where it behaves differently.

I have made sure that the bed's belt is tight. I check the wheels.under the bed. I cleaned them with a rag. When I turned them by hand, several were slipping against the rail (not causing the bed to move when I turned the wheel.) I tightened their bolts and that tightened some of them against the rail but a couple others still slip against the rail. Is this important? After these adjustments and turning printer on, "Auto home" worked and the steps on "Bed Auto Leveling" also did the correct things. I will report on more post-adjust experience as I get it.

Ever since I tightened the Y-axis belt and wheels I have not had the problem happen again having done 10+ prints. I tried the gcode that @octopus8 suggested at various speeds and the print head always ended up back where it started.

I will keep printing and if I experience the problem again I will investigate more then.

  • 1
    $\begingroup$ Hi Brett. The question is what did you check already? The issue may (more or less probable) be anywhere, starting from the firmware, through mainboard (drivers, signals), electric conductivity (cables, plugs, etc.), stepper motor, to the condition of movement mechanisms like wheels (belt, wheels, etc.). Is it completely random? Maybe some wire is broken, and sometimes does not work? Can you reproduce it (e.g. always from the same location)? Can it be related to movement speed (motor loosing steps)? - decresase in config. Anytime during print? When moving by hand, is it always easy and smooth? $\endgroup$
    – octopus8
    Commented Feb 20, 2021 at 9:53
  • $\begingroup$ Thanks @octopus8. I will start to do some of the things you suggest and report my results in original post. I also amended my post to indicate my CR-10S is used. $\endgroup$ Commented Feb 20, 2021 at 14:47
  • $\begingroup$ Ok, so it does not feel like mechanical problem... Maybe too fast movment? I tested behavior moving around the bed (simple square), by using simple gcode file (or just sequence of commands sent via serial terminal): G28 G0 F900 G0 X200 Y0 G0 X200 Y200 G0 X0 Y200 G0 X0 Y0. I then increase speed (the F value) by increments (like x2 or +900) and how steppers behave. This or similar way you could try to detect repeatable issue. $\endgroup$
    – octopus8
    Commented Feb 20, 2021 at 18:18
  • $\begingroup$ Can you please explain how I make this file. Is it something I can do in Cura or can I just create a text file with that content with a text editor and save the file as "test.gcode"? $\endgroup$ Commented Feb 24, 2021 at 2:47
  • $\begingroup$ The text file. Use any plain text editor to create file on SD. Also check how to What is a printer console/terminal?. The G-code is actually the way to communicate with your printer's firmware - except for LCD controller, but many things are not available via LCD. I use it a lot, so I advice to learn the basics: there are few common commands, plus many extended. You may read the intro from Wikipedia and check details of particular commands from reprap.org, Marlin Firmware. $\endgroup$
    – octopus8
    Commented Feb 24, 2021 at 7:27

1 Answer 1


octopus8 recommended doing a series of tests to determine the cause of the problem.

I started with moving the bed by hand (remember to have machine off or choose "Disable steppers" from "Prepare" menu) and the movement was relatively smooth with some resistance, the same as when moving the X-axis. If you move very slowly you can feel slight, small "steps", this is normal. The movement was consistent across the range of movement.

Since this did not indicate a problem, I moved on to checking the drive belt and the bearing wheels. The belt had a small amount of slack which I tightened. Several of the wheels under the bed slipped against the rail they run along. I tightened these. This improved the movement of a couple of them but a couple still slipped a bit.

After this I did not have the problem anymore. For 10+ prints over a week or so, there was no incorrect Y-axis movement and "Auto home" always worked. Nevertheless I continued with the next test suggestion which was to send some simple gcode to the printer via USB. I used both Ultimaker Cura 4.8.0's Monitor mode as well as [sending the commands from the linux terminal][1]. I sent the commands

G0 F<speed> 
G0 X200 Y0 
G0 X200 Y200 
G0 X0 Y200 
G0 X0 Y0

with values of 900,1800,2700,3600 and 4500 for and everytime the print head returned to the same place.

This is evidence that the tightening of the belt and wheels likely fixed the problem. [1]: How to directly send G-code to printer from a Linux terminal?

  • $\begingroup$ Many advices around say to make still possible to turn wheels in place with 2-3 fingers using force. In place, meaning not moving the device (bed for Y, carriage for X, gantry for Z). Otherwise wheels will wear quickly. For me it was pain to reach this state for gantry, because it requires ideal right angles between both "wheel setups" and a gantry level. Remedy is to start from tightening wheeled parts ideally. Then add a gantry bar. Then avoid gantry going down by itself. So I had to tighten even more, changing angles. I had to repeat it few times until I learned how tight wheels shoud be. $\endgroup$
    – octopus8
    Commented Mar 4, 2021 at 17:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .