0
$\begingroup$

Recently I've had some problems with my printer. My board and drivers got fried. Long story short, Now I have MKS-Gen-L v1.0 with LV8729 for X,Y,Z axes and extruder with these steps/mm:

#define DEFAULT_AXIS_STEPS_PER_UNIT   { 100, 100, 800, 100 }

which works fine. BUT not during Z-Homing!!! It seems that theses number are correct for every movement but while I'm Z-Homing (and also during bed leveling), my Y axis move twice as expected. My probe ends up being at the end my bed! changing steps/mm to 200 for Y axes just makes bed leveling impossible and my prints stretched.

I've been searching on the internet and changing every setting I knew about. still no clues. what's the problem???

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.