1
$\begingroup$

I've had the BLTouch working fine using this kit and following the instructions it shipped with.

I wanted to increase the number of probe points so I've attempting flashing with Marlin to achieve this. With the home-brew Marlin the probe doesn't extend for homing, with the default Creality firmware.

I'm running an Ender 3 Pro on 4.2.2 Mainboard. The wiring diagram has used the Z endstop connector for the BLTouch, I've followed this video, but clearly the wiring mechanic is different.

I've included:

// Force the use of the probe for Z-axis homing
#define USE_PROBE_FOR_Z_HOMING

But it has no effect. x and y work fine, but at z the probe doesn't extend.

Since it boils down to some setting changes in the firmware (since that's the only thing that has changed) I'm hoping someone has the answer to this question already. Unfortunately, I can't find any Creality source code for comparison and since it is working on their firmware and not the home-brew my expectation is I've missed a setting.

$\endgroup$
3
  • $\begingroup$ Hi welcome to 3DPrinting.SE! How would we know if you have missed a setting? You should at least link to the config files by pasting them on PasteBin or something. Note that Creality runs Marlin themselves, so it must be a setting indeed. $\endgroup$ – 0scar Feb 22 at 6:59
  • $\begingroup$ I've made numerous changes to various settings, I can post the current config, but it wont reflect the attempts I've so far made to try and resolve the issue. The file i've copied from is the creality v 4.2.2 config from here: github.com/MarlinFirmware/Marlin/tree/bugfix-2.0.x/config I'll copy it into the post if it will help $\endgroup$ – ANS Feb 22 at 8:08
  • $\begingroup$ There are pre-configured configuration files to be found for most Creality printers here, you could start there instead of a vanilla configuration file. You can also look into TH3D firmware if you're not comfortable with the settings in Marlin, TH3D has made it a bit simpeler with all settings at the top. $\endgroup$ – 0scar Feb 22 at 8:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.