3
$\begingroup$

I decided to finally purchase an Ender 3 v2. It arrived today and after a few hours of making sure everything is straight, I tried to power it and do a test print...

I was disappointed to see that the screen stays black after more than 10 seconds from power on.

I did not insert any SD card in the printer or anything that could interfere with the presumably stock firmware on it.

Because of this, I opened up the power source and the motherboard case and checked the voltages/checked LEDs. The motherboard blue led is on, the power source green led is on as well. I did a few measurements - I get 24 V to the motherboard with a small spike of 35 V when it starts.

The hotend fan is always on.

I checked the display connection and I am sure it is placed correctly.

I tried to upload firmware onto the mainboard first by clearing the SD card (8 GB given by Creality) using diskpart. I wrote the 4.2.2 (same as motherboard version) firmware version (stock) onto the SD attempting to upload on the mainboard. I tried renaming it, unplugging the power cable, unplugging the screen cable, etc and nothing would work.

I tried rewriting the DWIN_SET files but the screen would not turn to black/blue/orange colors. I tried more or less everything suggested here.

Is there anything I didn't do? What do you suggest? I already contacted the company where I bought it from, but I don't want to go through the assembly process twice - maybe I can make it work?


  • The correct voltage for the power supply is set at 230 V (Europe) and was set to this all the time. I tried switching it back and forth without power too. No result.
  • I've contacted the supplier yesterday.
$\endgroup$
3
  • 2
    $\begingroup$ Please confirm, that you have checked that the power supply voltage switch is right? How do you know your mainboard is working ok? Did you connect to it via serial terminal? (btw. Yes, the hotend fan is always on, which drives me crazy. I will install silent fan. But I also think of adding an extra switch or potentiometer just for this purpose.) $\endgroup$ – octopus8 Mar 5 at 6:29
  • 1
    $\begingroup$ Sounds like the screen might be damaged $\endgroup$ – Trish Mar 5 at 8:17
  • 2
    $\begingroup$ This is most probably a DOA, you should not tinker too much (checking if the cable is connected is fine, but don't do anything to radical) and get a replacement from your supplier. $\endgroup$ – 0scar Mar 5 at 9:05
1
$\begingroup$

I had the same issue. I think I flipped my display cable around and it worked. Maybe I got lucky and it was simply reseating the cable.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.