0
$\begingroup$

I am trying to run the G29 G-code for my 3D printer to automatically level the bed of the printer. Every time I try run the G-code my printer just beeps and nothing happens. Currently I am using Marlin 1.1.6 firmware.

Code for G-Code

; Default start code
G28 ; Home extruder
G29 P1 ; Auto Bed Level
G1 Z15 F{Z_TRAVEL_SPEED}
M107 ; Turn off fan
G90 ; Absolute positioning
M82 ; Extruder in absolute mode
{IF_BED}M190 S{BED}
; Activate all used extruder
{IF_EXT0}M104 T0 S{TEMP0}
G92 E0 ; Reset extruder position
; Wait for all used extruders to reach temperature
{IF_EXT0}M109 T0 S{TEMP0}
$\endgroup$
2
  • $\begingroup$ Are you sure the functionality is enabled? E.g. Marlin 1.1.6 is quite old, it could be that the option is not included. Could you edit the answer to include more information about how you are using Marlin 1.1.6. -> e.g. you build the firmware yourself or it has been build a long time ago and hasn't changed. Maybe linking to your configuration.h might be useful (e.g. on PasteBin). Do you use a sensor (UBL automatic) or manual (UBL with nozzle as probe)? $\endgroup$ – 0scar Mar 15 at 14:02
  • $\begingroup$ As far as I am aware it is automated. I am new to 3d printing. How do I go about retrieving/viewing the configuration.h file from Repetier-Host V2.1.6? $\endgroup$ – Warren Edy 12 Mar 16 at 6:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.