1
$\begingroup$

I've upgraded my board to SKR1.4 turbo with RepRap firmware. Heated bed and heated nozzle work, but motors do not move. OctoPrint reports them as 'no-driver-detected'.

Send: M122
...
Recv: Driver 0: position 67347, no-driver-detected
Recv: Driver 1: position 67347, no-driver-detected
Recv: Driver 2: position 67347, no-driver-detected
Recv: Driver 3: position 0, no-driver-detected
...

I tried to figure out what is wrong, but did not find good documentation for this combination of hardware.

This is how I setup the drivers.

  1. I removed all four jumpers from the board below each driver (MS0, MS1, MS2, RST).
  2. Plugged each driver to the board making sure that the corresponding pins match (GND to GND etc.)
  3. Checked voltage between ground pin of the board and VREF pin of the driver. The voltage was 1.365 V (same for each driver). This is a bit higher than some guides suggest, but the drivers worked perfectly with the old board.

Some guides suggest modifying driver timings if the motors do not move, but I was unable to find the right timings for my drivers. What could be wrong in my setup?

$\endgroup$
2
  • 1
    $\begingroup$ TMC2100s do not feature UART or SPI communication, so you won't get any results from M122. You'll want to set microstepping with the jumpers. VREF sounds reasonable. $\endgroup$ – towe Mar 17 at 12:53
  • $\begingroup$ @towe Thank you for explaining this strange message! Googling it gives nothing. I realised, that I relied on this message when trying different RepRap configurations. When I have time, I will try them once more with some basic movement commands instead. $\endgroup$ – Ivan Gankevich Mar 18 at 13:38
1
$\begingroup$

As @towe mentioned, 'no-driver-detected' messages in Octoprint log are harmless if you have TMC2100 motors. After experimenting with RepRap settings I found the correct configuration that works with my hardware. Here is the relevant part of the configuration.

; Drives
M569 P0 S1                                     ; physical drive 0 goes forwards
M569 P1 S1                                     ; physical drive 1 goes forwards
M569 P2 S1                                     ; physical drive 2 goes forwards
M569 P3 S0                                     ; physical drive 3 goes backwards
M584 X0 Y1 Z2 E3                               ; set drive mapping
M350 X16 Y16 Z16 E16 I1                        ; configure microstepping with interpolation
M92 X100.00 Y100.00 Z100.00 E100.00            ; set steps per mm
M566 X1200.00 Y1200.00 Z1200.00 E300.00        ; set maximum instantaneous speed changes (mm/min)
M203 X48000.00 Y48000.00 Z48000.00 E1500.00    ; set maximum speeds (mm/min)
M201 X1500.00 Y1500.00 Z1500.00 E1000.00       ; set accelerations (mm/s^2)
M906 X1000 Y1000 Z1000 E800 I30                ; set motor currents (mA) and motor idle factor in per cent
M84 S30                                        ; Set idle timeout
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.