6
$\begingroup$

So I have been having an ongoing problem with my printer that I just can't solve. I don't usually ask the questions on stack exchanges until my problem gets unsolvable. Unfortunately like this one

Printer: Creality Ender 3 V2

Current Board: Creality v4.2.7 (Silent Motor)

Background: This started when I accidentally fried the T20 chip on the v4.2.2 mainboard when I tried to install the BLTouch incorrectly (I looked at the photo upside down) and and also accidentally pulled the wire out and what I guess is why the T20 chip was fried. I thought at first the PSU was the one causing the trouble at first so I replaced it. Then found the burnt chip and decided to upgrade the board to a v4.2.7. I installed everything correctly according to a video that I found somewhere on YouTube.

Current Problem(s): When I turn on the machine the light on the mainboard is on but there is continuous beeping coming from the display with small clicks like a clock every 1 sec. or so. The backlight to the display is on but nothing is shown. I just found with a multimeter that the bed and nozzle terminals give no volts back.

Firmware: I have tried to update the firmware to the official one off of Creality's website and also using the source code for Marlin v2.0.7.2 with PlatformIO. The tutorial I followed was here:

Update [3/24]: Found that the firmware seems to not flash even after giving the .bin file a different name.

Extra Thoughts: I currently have no idea what to do. I think I might replace the LCD and its cable. I have only printed a few things and just want to get back to it but I don't want to buy a whole new printer to do so. I feel like I get closer to getting back to it every time I fix something but I'm starting to lose hope that it's just a never ending problem loop. I appreciate any help given.

$\endgroup$
12
  • $\begingroup$ v 4.2.7 of what? is that a creatlity boars? What video did you watch? It reeks of mis-configured firmware. $\endgroup$
    – Trish
    Mar 22, 2021 at 9:48
  • $\begingroup$ Yeah, it's the creality board v4.2.7(silent motor) amazon.com/dp/B07TFTVTXK/…. And there are a lot of tutorials but I think the one that I watched was youtu.be/y87P7K5DTMU cause it was pretty simple. I did no major changes to the marlin firmware except change the bed sizing and environment. $\endgroup$
    – Casheridan
    Mar 22, 2021 at 16:44
  • $\begingroup$ Also it was doing the same problem even without the firmware change. I tried it straight out of the box and got this problem then tried flashing the firmware but still got the same problems. $\endgroup$
    – Casheridan
    Mar 22, 2021 at 16:47
  • $\begingroup$ When you say you tried to compile your own Marlin firmware, which files did you pull for your configuration settings? Did the firmware successfully compile? $\endgroup$
    – Rykara
    Mar 22, 2021 at 18:18
  • 1
    $\begingroup$ Could be a bad or incorrectly formatted SD card. I think the card needs to be FAT32 format. Try reformating and/or using a different SD card? $\endgroup$
    – Rykara
    Mar 25, 2021 at 1:09

1 Answer 1

3
$\begingroup$

Thanks to @Rykara, they led me to the answer. The whole problem was kinda a firmware issue but on the SD card side. The reason why it wasn't flashing was because I didn't flash the SD card to use the FAT32 format. Unfortunately I tried every other format option except that one before hand, mostly because I am mainly on a Mac. Now there is no more problems and I am back on track to printing. :)

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .