3
$\begingroup$

I'm new to the 3D printing world and got my first Ender 3 (with the 32-bit controller board).

I have a problem with every single print. I've upgraded to the newest Marlin firmware, did the mesh leveling then started printing and fix the Z bed option in "Tune - Z bed" during the print (so the first layer is perfect). Please note that I save all the data of the mesh before end of the print. Then, when I start the same print again, the nozzle height is wrong. This happens every single print. The strange thing is that I need to adjust the height differently after every print. Like, the first print was -0.055 mm, second print was 0.30 mm, then it was +0.25 mm somehow.

I really like to print without these constant adjustments.

$\endgroup$
3
  • 1
    $\begingroup$ Are you using the stock Z homing switch or have you added a Z sensor on the print head (eg a BLTouch, etc)? $\endgroup$
    – Rykara
    Mar 26 at 17:13
  • $\begingroup$ Im using the stock homing switch. No BLTouch $\endgroup$ Mar 26 at 21:12
  • 1
    $\begingroup$ Hmm. Usually, if your Z Min is changing it's because your bed isn't level or is warped and you're measuring in different spots. Or using different paper. Or your bed/nozzle are at significantly different temperatures between measurements. Or it could be your Z axis rod is slipping and needs tightened.... $\endgroup$
    – Rykara
    Mar 27 at 7:04
3
$\begingroup$

It sounds like your bed is unstable. This is what I had to do with my Tronxy X1, and I fixed it by installing a decent bed stabiliser. Now that I have a stable bed, I only have to re-level it occasionally. However, the Tronxy X1 is a cantilever printer with a single rail for the bed, not an Ender 3.

I would suggest that you tighten the bed-levelling springs as far as they will go whilst still leaving sufficient movement for bed levelling, and re-position the end-stop switch. Then re-level the bed. If that doesn't work, try fitting stiffer springs. Upgrades are available for the Ender 3. If that still doesn't work, look for bed stabilisation solutions for your printer.

Note also that the bed-levelling knobs have a reputation for coming loose on the Ender 3. Tightening the springs (or fitting stiffer springs) may cure this, but some users fit locking nuts to stop the knobs moving.

$\endgroup$
2
  • 1
    $\begingroup$ Might just be a bad end switch if the deviation is so slow - and uniform over the whole surface. Bed screws moving on their own usually also skews the leveling itself. $\endgroup$
    – towe
    Mar 29 at 6:09
  • 1
    $\begingroup$ @towe One would think so (and you may be right). However, with my old bed carriage, it didn't seem to be out of level (although it is a rather small bed), but I had to check the bed height for every print, and it often required adjustment at all corners, so much so that it became part of my work-flow. When I installed the new bed stabiliser, the problem vanished. I was absolutely gob-smacked, especially as I had been struggling with the problem for 3 years. I now consider myself to be an expert bed-leveller (at least, on my printer type). $\endgroup$
    – Mick
    Mar 29 at 10:46
0
$\begingroup$

Thanks everybody for their help, but apparently it was a slicer/software/gcode (i don't really know :D) issue...

So i just added this line M420 S1 after the G28 command to my Cura printer settings and now the nozzle height is always at the point i set before, no changing every print.

Hope my solve will help somebody who is struggling with this too!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.