2
$\begingroup$

I tried to slice an stl file using the PrusaSlicer console and I got the No layers were detected. You might want to repair your STL file(s) or check their size or thickness and retry. message. I tried repairing the model with 3 different services and I still get the same error. When I load the fixed stl file into the PrusaSlicer gui, it doesn't say that the model is broken. How can the console and gui give 2 different results and how can I fix this?

Here's an image of the model being loaded into the gui version. It states that the model is broken but was automatically fixed.
broken model
Then I manually fixed the model using Netfabb and the model is no longer broken according to the gui version.
fixed model
Yet when I try to slice the repaired model using the console, it fails again. error message

PrusaSlicer version is 2.3.0 on Windows 10.
You can find the stl and repaired stl here.

$\endgroup$
3
  • $\begingroup$ Cura says, those files are perfectly fine.. $\endgroup$ – Trish Apr 6 at 16:30
  • $\begingroup$ Yes I know that the files are fine, I don't get why the console slicer is still producing that error. $\endgroup$ – Brent Apr 6 at 16:59
  • $\begingroup$ degenerate faces are faces that do have no surface area... maybe internal geometry? $\endgroup$ – Trish Apr 6 at 19:26
1
$\begingroup$

Still don't have an actual answer as to why repairing the stl file didn't seem to work, but since my stl file was a combination of different stl files I tried repairing the individual stl files before combining them, which resolved the problem.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.