2
$\begingroup$

I have an Ender 3 v2 and just installed the Ender Extender 400XL and a new BLTouch. I need to modify firmware for the new dimensions of 400x400x500 mm for the new kit.

I changed all that and it seems to find the physical end stops, I haven't tried printing yet.

But the BLTouch is an issue, at first it refused to move down as the pin was always up, so I changed: #define Z_MIN_PROBE_ENDSTOP_INVERTING to true from false. Originally, the probe would tricky and stick to a triggered position. when changing it the true the probe now deploys but that's it.

But, now when using the leveling feature it goes to the X an Y physical end stops, then goes to the middle of the bed, a few inches from the bed, doesn't do anything else and the software freezes.

I can't figure out why its locking up and why the Z wont move.


I tried using a Marlin firmware 2.0 for Creality Ender 3 v2 and I also tried a custom one for an Ender 3 v2.

What happens now: If I use auto home it hits the Y and X end stops perfectly, go to the center of the bed the pin drops and retracts several times but the Z axis never moves.

If I try to use the leveling function the same happens, it gets to Z, the probe drops and retracts, Z never moves but then the software locks up completely. I have to power cycle the printer.

Note, If I take the original firmware from https://www.creality.com/download it works, as expected. But of course it has the wrong dimensions as it is expecting the standard bed size not the XL Upgrade!

$\endgroup$
1
  • $\begingroup$ Hi Riki, welcome to 3DPrinting.SE! Please expand your question to include what you exactly set to true and what firmware you actually have used to base the configuration on. E.g. is this vanilla Marlin or Creality firmware? Please explain if the printer already had a working BLTouch prior to the upgrade to the 400XL or not. Also linking to your configuration files in comments might be helpful. This sounds as an incorrectly configured printer. Detailed information for the configuration of the BLTouch is found here. $\endgroup$ – 0scar Apr 11 at 5:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.