1
$\begingroup$

As the title says, I have an Ender 3 Pro + BLtouch v3.1 and BigTreeTech SKR mini E3 v2.0. I have the SKR loaded with "firmware-bltouch-for-z-homing.bin" but my printer does not seem to be auto leveling. I'm fairly new to 3D printing and I have no idea what I am missing. My bed seems pretty warped but that isn't an issue for small print. For larger prints I think I think I need to enable mesh bed leveling but I'm not sure how.

I have my start G-code setup as:

; Ender 3 Custom Start G-code
M140 S{material_bed_temperature_layer_0} ; Set Heat Bed temperature
M190 S{material_bed_temperature_layer_0} ; Wait for Heat Bed temperature
M104 S160; start warming extruder to 160
G28 ; Home all axes
G29 ; Auto bed-level (BL-Touch)
M420 S1; enable auto bed-level?
G92 E0 ; Reset Extruder
M104 S{material_print_temperature_layer_0} ; Set Extruder temperature
G1 X0.1 Y20 Z0.3 F5000.0 ; Move to start position
M109 S{material_print_temperature_layer_0} ; Wait for Extruder temperature
; G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; Draw the first line
G1 X0.4 Y200.0 Z0.3 F5000.0 ; Move to side a little
G1 X0.4 Y20 Z0.3 F1500.0 E30 ; Draw the second line
G92 E0 ; Reset Extruder
G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
; End of custom start GCode

It heats up the bed, does the 5x5 auto level and then heats the extruder but when printing I do not see the Z axis moving throughout the first layer to compensate for the warped bed.

Any help would be greatly appreciated.

Should I be using "firmware-bltouch.bin" instead and reinstall my Z switch?

$\endgroup$
0
$\begingroup$

Again another nightmare for 3d printer users - it took me days to figure it out.

My Ender 3 bed was warped in the middle. I got a glass bed, which helped.

I installed the BLTouch and used the Ender 3 Pro firmware. It gives you the options in the menu. I also added the G29 code to G-code.

But it's not perfect. I needed to manually adjust the Z-probe.

$\endgroup$
1
  • $\begingroup$ Welcome to 3D Printing SE and thank you for your contribution. When you get a chance, please take the tour to understand how the site works and how it is different than others. $\endgroup$
    – agarza
    Apr 21 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.