1
$\begingroup$

There are a few hits on my issue title but could not find an actual answer/advice. I burned my Ender 3 Pro Creality motherboard and replaced it with an SKR 1.4 + TMC 2209 + BLTouch. Everything is moving like it should and calibrated.

However, at the end of the homing process, the Z-axis goes up, then it's supposed to move to the printing position. At that point, the acceleration is so great that the Z-axis barely goes down and I end up printing about 4 cm above the bed.

These are the settings I changed on my Marlin 2.0.7 firmware in relation to the Ender 3 setup:

Configuration.h
set #define STRING_CONFIG_H_AUTHOR "Nicolas Rietsch v 0.1.2"
enable #define CUSTOM_MACHINE_NAME
set #define CUSTOM_MACHINE_NAME "Ender-3 PRO"
set #define TEMP_SENSOR_BED 1
set #define DEFAULT_MAX_FEEDRATE          { 500, 500, 5, 45 }
set #define DEFAULT_MAX_ACCELERATION      { 450, 450, 100, 10000 }
set #default DEFAULT_ACCELERATION          450
set #define DEFAULT_TRAVEL_ACCELERATION   500 

set #define INVERT_X_DIR true
set #define INVERT_E0_DIR true
set #define X_MIN_POS -26
set #define X_BED_SIZE 230
set #define Y_BED_SIZE 230
set #define Z_MAX_POS 250
enable #define NOZZLE_PARK_FEATURE
Configuration_adv.h
set #define X_CURRENT       500
set #define Y_CURRENT       500
set #define Z_CURRENT       500
set #define E0_CURRENT      650
set #define CHOPPER_TIMING CHOPPER_DEFAULT_24V

What am I missing?

$\endgroup$
1
  • $\begingroup$ DEFAULT_MAX_ACCELERATION... what is your current value for Z in EEPROM? Have you checked acceleration settings using LCD or g-code? Or reset to defaults? $\endgroup$
    – octopus8
    Apr 28 at 17:05
0
$\begingroup$

Maybe it would it help if you fix #default to #define in the current line:

set #default DEFAULT_ACCELERATION ...
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.