1
$\begingroup$

This issue just started recently; I am not sure if it is because of the specific part I am printing or whether something on the printer is going bad. Up until now, I have been printing all kinds of parts with no problems whatsoever.

I am printing a hollow sphere whose walls have fill paths that require the X and Y to change rapidly. i.e. the wall is 2 mm thick and the wall-line-count setting is set to 2.

When the print head is jerking back and forth to fill in this area it causes horrible vibrations and really bad Y layer shift. You can see the vibrations transferred through the flexible neck of the black LED light in the foreground.

All the Cura settings are at default- I have not tried to speed up my printing in any way by adjusting the settings.

The vibration seems to be coming from the Y stepper.

I have already tried tightening the belt; everything else seems tight.

It is an Ender 3 Pro with a stock mainboard and probably around 50 hours on it +/- 20 hours.

I have printed the same part on my other printer with no issues.

This is happening now on other parts that do not have particularly high jerk paths, it is shifting the Y by a full mm or more at a time.

Would you say the stepper motor is going bad? Or the driver? Or something else?

Here is the part in the video; I of course stopped the print after it started shifting:

enter image description here

And this is how it is supposed to look:

enter image description here

EDIT:

Here is the path that causes the problem:

enter image description here

$\endgroup$
0
$\begingroup$

Your video doesn’t show a printer moving terribly fast, which makes it seem like it could be a problem with the motion or the electronics. Check the movement of the Y axis by hand, is it smooth? With the belt on, and the stepper motor attached, you’ll feel some resistance and little bumps, from the steps in the motor, but it should be pretty smooth, and especially it should be consistent across the range the bed can move. If you take the belt off, the motion should be like butter. Check the belt pulley isn’t slipping on the motor shaft. Check the idler on the other end of the belt spins freely.

The motor could be suspect, the driver could be suspect. Try running the printer so it sends the bed back and forth, and push against it with your hand a little as it moves. It should be pretty strong, and shouldn’t skip steps from some light pressure. If it does skip easily, it’s something with the motor or driver, or possibly the wiring to the motor (I had a failing connection on my extruder stepper that manifested as wimpy torque and skipped steps). You can beep the wire with a multimeter, and wiggle it around as you beep in case it is a loose/flaky connection. I’m not sure if the creality printers have trimpots for the motor drivers, but some drivers have a bias adjustment where you adjust a voltage with a multimeter, to decide how much current the motor gets. It’s not usually something that goes out of adjustment.

If it doesn’t skip steps easily from adding some resistance with your hand, then it might be an incorrect jerk setting on the printer, or the slicer travel speed is too fast, or, the hot end is hitting some plastic that is sticking up (an overhang curled up possibly), and skipping a step there maybe.

$\endgroup$
4
  • $\begingroup$ It requires significant manual pressure to cause skips. With the stepper off the axis moves pretty smoothly. The bed moves fine with the belt off. $\endgroup$ May 5 at 0:37
  • $\begingroup$ I have tried printing the same part again with the jerk turned down to 6 (from 20) and it seems to have remedied the vibration. The part is printing fine now. I do notice now how small the actual jerk motion was in the relevant section of the path. It is hard to see any motion from a distance but it is there when viewed from close up. Is it possible that the rapid alternating of the current caused by the path caused the driver to overheat? I had read elsewhere that one guy had to add additional cooling to his ender 3 to avoid his drivers overheating. $\endgroup$ May 5 at 0:39
  • $\begingroup$ I added a jpg to the OP of the sliced path of the layer around where the vibration started previously. As you can see that yellow center is what caused the head to change direction so rapidly. I'm not sure if this happened because of something new that is going wrong with the printer, or if it happened simply because this is the first time I have ever tried to print something with such a path. I only know that this same part printed fine on my ender 5 with default settings. Of course the ender 5 also has a much more voluminous mainboard enclosure and better cooling. $\endgroup$ May 5 at 0:57
  • $\begingroup$ If this is the old 8bit board, it will skip steps at 20 jerk. This is probably a Marlin bug running on slow microcontrollers. $\endgroup$ Jun 5 at 4:29
0
$\begingroup$

It looks like your printer is working at it's resonating frequency. If the things you mention in your response to ChinchillaWafers is still not good enough, try using different printing speeds or different fill patterns.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.