2
$\begingroup$

I have the community edition of the firmware for my CR-6 SE printer installed on a BigTreeTech SKR-CR6 V1.0 board. This firmware has a nice E-step calibration guide you can use to easily get the correct step/mm value.

However when I raise that value, my extruder motor starts to chop, it's like it doesn't have enough strength to push the filament through and starts chopping.

I tried raising the current on the extruder motor, from 600 mA which is standard, to 900 mA incrementally, but it didn't make any difference.

I just replaced the stock extruder with a dual gear extruder in hopes that the extruder was causing this. but the new extruder faces the same issue.

I think raising the Vref value for the extruder motor might help, but I don't know how to do that. on the BTT SKR-CR6 V1.0 board all stepper drivers are in UART mode so there is no way to change this on the board itself. and there is no way to change Vref in the UI as far as I know.

What should I do to progress with this issue?

$\endgroup$
1
$\begingroup$

You cannot change the Vref of a UART operated stepper driver, setting the current directly is the way to go on UART operated stepper drivers; in fact that is actually what you are doing on non-UART operated stepper drivers, you change the Vref to change the current through the stepper motor, the higher the voltage the higher the current through the stepper the more torque the stepper has.

Depending on the stepper you may increase the current even more, this depends on the stepper motor model/type. There are stepper motorss that allow more than 1000 mA, I don't know the steppers used in the CR6 E, find out before you test higher values.

Please note that there may be something else causing this issue, possibly your filament path is having a lot of resistance. You should check the extrusion manually and possibly clean the nozzle and heat break.


A similar question is found here: Is the Vref trimmer relevant on TMC2208 in UART mode?

$\endgroup$
3
  • $\begingroup$ I've been thinking of replacing the nozzle with a brass one, this is a (probably steel one) that was included with the all metal hot end that I replaced with as soon as I got the printer, it's not old. but that might help. I do have replacement stepper motors for the extruder as I had problems with my previous printer, but it turned out to be a faulty controller board in the end. so the question is, if I were to crank up current to 1000 mA and motor burns because of it, do I risk causing damage to the stepper driver? $\endgroup$
    – inifus
    Jun 8 at 11:38
  • $\begingroup$ Regarding the high currents, please read this. $\endgroup$
    – 0scar
    Jun 8 at 12:30
  • 1
    $\begingroup$ That was a good read! Seems like my stepper should be rated at 1.5 A so it should be safe to crank it up to 1.3 A to see if it has any bearing on the choppiness when I raise my E-steps. $\endgroup$
    – inifus
    Jun 8 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.