2
$\begingroup$

I have very strange problem. Motors X and Z are messing up somehow. I mean if I try to home X only, Z moves also. And vice-versa. Y motor homes and moves normally.

Board is stock E3v2 v4.2.2 with TMC2208. With Marlin everything is OK.

Also, I'm not sure if it's important, but I have compiled firmware 3 times and all 3 are different in size - 20424 bytes first, 20540 bytes second, and 21172 last. All with the same settings -> STM32F103, 28kbit bootloader, com only (USB, CAN disabled).

Heaters seem to work too.

Video (I'm not sure how to add a video window here)

Here is my config for motors:

[stepper_x]
step_pin: PC2
dir_pin: PB9
enable_pin: !PC3
microsteps: 16
rotation_distance: 40
endstop_pin: ^PA5
position_endstop: 0
position_max: 225
homing_speed: 50

[stepper_y]
step_pin: PB8
dir_pin: PB7
enable_pin: !PC3
microsteps: 16
rotation_distance: 40
endstop_pin: ^PA6
position_endstop: 0
position_max: 225
homing_speed: 50

[stepper_z]
step_pin: PB6
dir_pin: PB5
enable_pin: !PC3
microsteps: 16
rotation_distance: 8
endstop_pin: ^PA7
position_endstop: 0.0
position_max: 250
$\endgroup$
4
  • $\begingroup$ You should probably create an issue about this on the Klipper Github (github.com/KevinOConnor/klipper/issues) Maybe something about the shared enable pins? The HAL itself for the F103 works fine from my experience. Make sure your kinematics: in the [printer] section is set to cartesian $\endgroup$ – towe Jun 15 at 7:05
  • $\begingroup$ Don't open a ticket on Github, read the documentation: help requests go to the Discord channel. $\endgroup$ – FarO Jun 15 at 8:48
  • $\begingroup$ Also, check connections: maybe you inverted some cables. $\endgroup$ – FarO Jun 15 at 8:54
  • $\begingroup$ "Make sure your kinematics: in the [printer] section is set to cartesian" Thanks, that help! $\endgroup$ – Minkoff Jun 15 at 12:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.