4
$\begingroup$

My BLTouch was working great. Until one day, it just started showing the right side as being high on every read.

I've tried leveling many times manually and with the BLTouch. But every time I use the bed visualizer, it shows high on the right. I've even rotated the glass build plate with the same result.

Any ideas what could be causing this? The bed leveling image below was done immediately after manually leveling the bed.

3D graph of bed mesh

$\endgroup$
2
$\begingroup$

I think I found the problem. I think there was some crosstalk between the BLTouch wires and the other wires it was tied together leading to the hotend. When I moved the BLTouch wires away from the others the problem went away.

I will be added a sheild to the cable in the future like in this youtube video

$\endgroup$
0
$\begingroup$

The OP already found the problem and answered the question hinting to shielding of the cable. If this is the actual problem, of fiddling with the cables might have caused this, an alternative solution is presented as I've experienced similar behavior.

If one side of the bed is higher than the rest, even when rotating the glass bed, you might experience that the nozzle carriage is tilting on that side. E.g. when using a Bowden extruder assembly, a too short Bowden tube (or cables in a non-Bowden setup) the tube (or cables) pull at the carriage causing it to lift at the furthest points from the extruder; this tilting can cause the nozzle to go up a few tenths of a millimeter.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.