1
$\begingroup$

I´ve been using my Ender 3 Pro for almost 1 year now. Always using the provided SD card. For a couple of days, the printed does not read any new file that I load to the SD card, but it does with the older files (and it then prints correctly as well).

I tried deleting some old files that I don't need, I tried turning it on with the SD card, I tried inserting the card after turning the printer on. It's always the same.

I am using another SD card and it works properly.

Any idea?

$\endgroup$
2
  • $\begingroup$ Welcome to 3D Printing Stack Exchange! Please take the tour and read over the FAQ to get a better idea of how Stack Exchange works. $\endgroup$
    – Zeiss Ikon
    Jun 18 at 12:01
  • $\begingroup$ The original card I got with my ender3 also wore out recently. $\endgroup$
    – user10489
    Jun 19 at 5:41
0
$\begingroup$

SD and MicroSD cards use a type of memory (Flash RAM) that is subject to wearing out -- the actual memory cells deteriorate very slightly each time data is written to them, and SD, MicroSD, and thumb drives typically don't use the very best flash RAM (as would hopefully be the case for internal Solid State Drives that house the operating system and user storage in your computer).

Further, the constant plugging and unplugging of these cards also puts wear on the connectors.

Either of these factors can result in one or more devices losing the ability to read the card, and this can result in only old files being accessible (though it's much more common for the card to become read-only, or even become unreadable).

If you can still read the original card in your computer, please make a complete copy of the contents immediately, and then write those contents to a new card (as well as keeping a copy on your computer's storage) -- and throw the old card away, so you don't accidentally use it for anything.

$\endgroup$
0
$\begingroup$

Something in the Ender 3 stock firmware (and even custom Marlin builds) is prone to corrupting SD cards, especially if you've removed and re-inserted them without using the unmount command on the menu first. I never tracked down exactly what it was before switching away from Marlin, but whenever it happened, making a new directory, moving all the files to it, and deleting the old directory seemed to work (assuming you don't keep files in top-level directory) to get it to read them again. When that didn't work, moving them off to the host computer, reformatting the SD card, and moving the files back always worked.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.