3
$\begingroup$

I have a Creality CR-10 which is running Marlin because I have a BLTouch installed. All was working fine until it suddenly had an issue where it would lose connection to the computer mid-print when another electronic device nearby was plugged in.

For example: when I plug in my lamp or soldering iron which is 3 meters away, it just stops (doesn't reset, just stops moving) leaving the bed and nozzle hot. The software on the printer is still functional, I can still navigate menus, etc. on the screen but the print stops and can't be resumed from Cura.

I also tried Octopi but it does the exact same thing mid-print and the web interface spits out this error:
device reports readiness to read but returned no data (device disconnected or multiple access on port?)

So it seems I may have some odd interference problem, I guess it could be over the air or through the powerline? I've tried different USB cables, a different power supply for the Pi, but so far, it's still acting up.

$\endgroup$
0
$\begingroup$

I had similar issues when I first started, and I think you are on the right track with interference being a problem.

I have a giant bin of USB cables and started going through them. Only 2 worked out of about 20, and 1 of those 2 was intermittent with disconnect issues. The one that ended up working had gold plated leads and was about 8" long. I assume it probably has some additional shielding of the wires inside as well but I can't say for sure. It seems that the USB connection is very sensitive to interference.

Also, if it is anything like my Ender 3 V2, you will probably want to use Kapton or electrical tape on the last pin (+5v) of the USB plug, otherwise the display and motherboard kept powered on after turning off the printer's power supply (it was being powered over the USB cable).

Another suggestion would be to isolate the printer power supply from other devices (for example using a UPS made for a PC).

$\endgroup$
2
  • 2
    $\begingroup$ Ok, I narrowed down the problem to USB interference. I powered the printer's 12v line from a battery, that way there isn't going to be any interference through the mains. However, it still does stop during the print when i turn the lamp on. I tried SD printing which worked flawlessly, so the problem must be something to do with USB, i'll try the 5v pin trick later today. $\endgroup$
    – Ramsom
    Aug 3 at 23:48
  • $\begingroup$ Hey there @Ramsom, Your comment seems like an answer If this answer helped you solve your problem please accept it to mark this question as 'solved', Or feel free to write your own answer if you solved your problem a different way! $\endgroup$
    – craftxbox
    Aug 16 at 13:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.