1
$\begingroup$

I have an Ender 3 Pro with a BLTouch 3.1 attached and I have this weird problem. Whatever I print, whether it's a 3rd party STL or my own design, the Z is always getting stretched up to a point and then it fixes itself.

i.e. I printed these calibration cubes at 100% and 150%. While there is a slight wobble on the X axis, X, Y and the top half dimensions are almost perfect.

Z prints higher than it should

Not sure if I had this problem prior to BLTouch installation, so I suspect that it might be messing Z jump between the layers somehow but no idea what to look for.

I am using TH3D's Marlin Firmware and I did nothing other than enabling the corresponding flags for BLTouch and ENDER_V44_BOARD when compiling the firmware.

  • The problem occurs on my custom designs and other models too, so it's definitely not the model
  • I tried to use Simplify3D, Ultimaker Cura, Prusa Slic3r to slice and then print with Octoprint, Simplify3D or Pronterface, it didn't make a difference.
  • I calibrated the E steps, so I am not no under or over-extruding.
  • I also tried to re-calibrate the Z steps so the height would match, which it did but didn't solve the problem. I now have a squished top half and a weird looking print.
  • The steps/mm values were at default, X80, Y80 and Z400 - as described, reducing the Z to 320 to compensate the height difference didn't help. See the picture below.

Squished top half after reducing the Z steps

I am pretty much stuck at this point, so I'd appreciate any guidance very much!

$\endgroup$
1
1
$\begingroup$

It seems the DEFAULT_LEVELING_FADE_HEIGHT of the TH3D firmware was causing the issue, which was something I was aware of but didn't think that it would cause this.

I set it to zero and then re-printed the calibration cube. It came out with the dimensions of 20 mm x 20 mm x 20.1 mm, which was incredibly accurate for the setup I have.

Related: Creality Ender 3 Pro - Z travel issue with TH3D firmware

$\endgroup$
1
  • $\begingroup$ Nice. Yet another reason I don't feel the need for BLTouch. $\endgroup$
    – Zeiss Ikon
    Aug 3 at 13:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.