2
$\begingroup$

Let me preface this with me being quite a newbie to 3D printing, however, I am an engineer and coder, so tinkering with stuff like this is quite the norm for me. Don't be afraid to be too technical, knowledge is power!

I recently purchased a new Creality Ender 3 V2 based on a friend's recommendation and within a week or two, started getting terrible screeching from the print head fan. I already knew I wanted to get better PETG (and in the future, TPU) prints so I went ahead and bought a direct drive extruder (BIQU H2) to replace the Bowden setup.

I got everything tuned pretty well (or so I thought), which included tuning the E-steps (945 which is 10x the original value of 93, however normal for this BIQU H2), my home position, changing the retraction setting, setting my K-factor for linear advance, tuning PID, etc. I flashed these settings into a custom Jyers Marlin firmware. Everything was working fine, and I was starting to get some really high-quality calibration tests, so I then began tuning my slicer profile.

Then, yesterday, all of a sudden it is no longer printing correctly, even older G-code files before I messed with the slicer settings. It prints the prime line, retracts, moves, prints the brim, then retracts again, but doesn't start extruding to actually print the model. I've tried multiple G-code files that were working, and seem to get the same results, nothing prints beyond the first layer retraction or two. There is no clicking/vibrating or any attempts to move the extruder again after it stops printing.

After some more reading, it seems that maybe I should have adjusted the vRef on extruder driver pots, as the new stepper motor is 0.8a (I believe the original 4042 extruder is 2a). Is it possible I damaged my stepper driver for the extruder? From my understanding, it would be moving at 10x the speed of the old stepper attached to the Bowden tube extruder.

Some things I have done:

  • Completely rebuilt the BIQU H2. There is no sign of jamming or that there has ever been a jam. The gears all move smoothly with no areas with additional resistance. The PTFE heatbreak was clear and freely allowed filament through. Once re-assembled, I can freely turn the extruder gear when heated and the stepper disabled, and I can extrude/retract using the printer GUI (even after a failed print). I also checked to make sure the gear was firmly attached to the stepper motor while apart, and it was. I also added some gear lubricant while I was in there.
  • Tried a print with the BIQU H2 stepper detached and the wires attached to the old 4042 stepper (and adjusted the steps back to 93). It seems to stop moving the stepper in about the same place, so I don't believe the issue has to do with the stepper motor which has led me to believe this must be firmware or driver related.
  • Tried letting the printer sit idle overnight, thinking maybe it was just an overheated driver after running calibration tests almost continuously for 2 days.
  • Tried printing the same known working G-code with the speed adjusted to 25% and 50%, the same issue occurs around the same position in the print process.

For reference, I have an Ender 3 V2 with a 4.2.2 Motherboard. I'm not sure what stepper drivers it uses as there seems to be conflicting info online and I don't really want to remove the heatsinks if possible (but I will if I need to get this info and can't obtain it directly from the firmware). Unfortunately, the drivers are soldered to the motherboard so I guess I will need a new motherboard if I destroyed the extrusion driver. I do feel I probably should have made some driver adjustments given this stepper motor is 40% the amps, and runs at 10x the speed of the old stepper.

I'm sort of at a loss as to what to try next, any thoughts would be appreciated. I plan on flashing the stock firmware back later this evening to see if that helps, but I doubt it will. I have only made some small tweaks mainly related to home offset, build area, PID tune, and K-factor for linear advance (which were previously working fine).

Edit: I did some further testing yesterday. Flashing back to stock firmware didn't help at all. It also seems I may have been mistaken as further testing of the old 4042 stepper was successful if I attached it to the motherboard and ran the G-code which fails on the first layer, however I attached it with a spare cable as to not have to take apart my harness going to the X carriage. Using the same spare cable with the BIQU H2 unfortunately did not help. The issue is reproducible without any filament loaded at all as well. There is an ever so slight play in the motor drive, so I am going to disassemble the extruder again tonight and see if the issue is reproducible with the motor detached from the extruder drivetrain.

Also, just an interesting point, but multiple times after the failure I quickly checked the temp of the heatsinks on the drivers. Ironically, the only "hot" ones were the X/Y/Z steppers, and the extruder driver was only warm. Also, when the issue happens, the stepper becomes completely disengaged (I can turn the wheel freely without feeling the resistance of the stepper holding the position). Not sure if this is indicative of a driver failure, or standard practice for the driver if it encounters significant resistance.

Another interesting point, the motherboard was not grounded. Although attached indirectly to the frame using screws, the panel the motherboard was attached to was not making contact with the frame. Some minor sanding resolved this issue. Once done, I notice the exterior case of my Y motor is grounded, but the X and Z as well as the extruder do not seem to be grounded. Is it typical for the exterior of the motors to be grounded? Perhaps there are some other ground faults I need to sort.

$\endgroup$
4
  • $\begingroup$ Check to make sure you don't have heat creep. See 3dprinting.stackexchange.com/questions/15629/… $\endgroup$
    – Perry Webb
    Aug 4 at 14:00
  • $\begingroup$ @PerryWebb I don't believe the issue is heat creep, as I didn't have any clogs or jams when disassembling. $\endgroup$
    – user995551
    Aug 4 at 20:40
  • $\begingroup$ Are you saying the extruder stopped moving? With heat creep the extruder keeps moving, but doesn't extrude and the nozzle isn't clogged. $\endgroup$
    – Perry Webb
    Aug 4 at 21:53
  • $\begingroup$ @PerryWebb Yes, exactly. The extruder just simply disengages from the driver mid print (the motor can free spin as if it was powered off). I believe I have sorted the issue now, thanks for your suggestion. $\endgroup$
    – user995551
    Aug 5 at 17:31
1
$\begingroup$

Okay, so after yet another frustrating night of troubleshooting. I believe I have identified the specific problem. I reduced the G-code file to about 100 lines of code, that 100% reproduced the issue on the BIQU H2 stepper. With the original 4042 stepper, the problem was intermittent, but did occur from time to time in the same part of the print.

I pulled the motor from the transmission on the BIQU H2 and observed the issue happen without it attached to the extruder and it still failed at the same place (so confirmed it wasn't an issue with the extruder/clogging/etc). This specific place in the G-code had many quick short movements of the extruder. Commenting out this block of code allowed it to get past, until it did similar movements on the next layer. This pointed me to it having to be an issue with either the stepper (which tested fine on my ohm meter, so unlikely), the controller, or the firmware.

Long story short: It was Linear Advance being enabled in the firmware.

I was too hasty to initially disregard the firmware being at fault. When I retested the original firmware, it was unusable as my offsets have changed with the new print head, so I rebuilt the Jyers Marlin with just a couple small changes for changing the homing as the original Jyers builds works fine. However I missed that I still had my Linear Advance settings enabled.

After doing some searching regarding Linear Advance and extruder motors, it seems this is a known issue with certain TMC drivers, and my board is one that can potentially have these drivers installed. It seems the "stealthChop" feature within the drivers causes issues with Linear Advance. It sounds like it can be disabled via UART but I do not believe there is any interface to the UART of the individual controller chips exposed to my mtherboard. I believe I will probably need to swap motherboards if I want to be able to use Linear Advance. I'm still pretty new to 3D printing, so maybe I don't need LA at all, however it did seem to make a positive impact on my prints before I ran into these issues which is why I had it enabled.

Some related references I found:

https://github.com/KevinOConnor/klipper/issues/196#issuecomment-383122655 https://www.reddit.com/r/ender3/comments/bncr8w/silent_board_and_linear_advance/

$\endgroup$
1
  • $\begingroup$ Hey there! As it seems you've solved your problem, you should be able to accept your own answer to mark this question as solved. Thanks! $\endgroup$
    – craftxbox
    Aug 16 at 13:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.