4
$\begingroup$

A few weeks ago I got a thermal runaway message on my modded Ender 3 during a print, and I have not been able to get it working since then! I have tried fixing and replacing everything, and I still keep getting the message!

When the printer starts/heats up, the thermistor is able to read the temperature with no problem, but when a print starts, the thermistor starts reading strangely and I get the thermal runaway message! Basically, whenever I start a print the temperature being read slowly drops until it gets to around 20 degrees below the set temperature. I then get the thermal runaway message.

So far, in an attempt to fix it, I have replaced the thermistor twice, the heating element, the wiring was replaced, the firmware and even the entire motherboard! I have no idea how/why I’m still having the message, it just doesn’t make sense.

Also, the thermistor is snuggly attached to the printer.

Please note I’ve tried another thermistor that was glass and had the exact same issues. This lead me to think that this had something to do with the heating element being overwhelmed by something. So, as a test I simply just extruded filament from my nozzle with my fan on to see if that would have the same effect and it didn’t! The temperature stayed up fine. This is leading me to believe that this is some sort of issue with starting a print. Maybe a G-code issue.

$\endgroup$
3
  • $\begingroup$ Approximately how long until you get the thermal runaway message after the first bit of plastic is extruded? Is this time consistent or does it change on every print attempt? $\endgroup$
    – Kezat
    Aug 8 at 0:28
  • $\begingroup$ About 30-45 seconds in. It is very consistant. I have even tried it at different temperatures with different materials and I still get the same results, with the temperature falling by about 20 degrees, then getting the thermal runaway message. $\endgroup$ Aug 8 at 17:04
  • $\begingroup$ Disconnect the fans and please try again. If the fan test is done at height, the flow path may be different then when above the bed, e.g. the bed may deflect the cooling flow to the heater block. Also check if the thermistor is correctly inserted and fastened. $\endgroup$
    – 0scar
    Aug 8 at 20:49
1
$\begingroup$

If the error only happens when the printer starts moving it's logical that the issue is in the wire loom that starts to bend and flex once the print starts.

As a quick test and if your comfortable with a little wiring work a temporarily line could be connected directly from the sensor to board. Skipping rewiring the loom until its confirmed to be the issue.

Same logic for the heater wires if it has a connector at the extruder.

Another potential cause for this is if the extruder is already near printing temperature and a new print is started, the printer could think that the temperature shot up way faster then expected even though in reality it was just a bit preheated. If you made any changes to your start G-code, like changing the heating command type or order in witch the extruder/bed is heated, see this stack: Thermal runaway triggers when raising temperature amid cooldown.

Edit: This video demonstrates a test to show if Thermal Runaway is enabled. While this setting is not in question here it might be a way to troubleshoot the underling cause for this kind of issue. If the extruder temperatures drop rapidly the same way it does when a print is attempted it might show that the temperature sensor is reading the correct temperature. And thus may indicate a issue with the extruder heating system and not the temperature sensor itself.

$\endgroup$
3
  • $\begingroup$ The wiring was replaced. I showed this to my friend and he pointed out that other people were having the exact same problem with the same thermoster I had, where it is easily damaged/messed up by tension in the connection. Here is the thermoster: amazon.com/Gulfcoast-Robotics-Thermistor-Creality-Printers/dp/… $\endgroup$ Aug 7 at 1:29
  • $\begingroup$ @Twinkletoes Apologies I cant yet comment directly on your comment above. So you have tried a total of 3 sensors now? The last one was the glass one? Or are we at two? For each sensor swap was the cable also changed out each time? $\endgroup$
    – Kezat
    Aug 7 at 2:56
  • $\begingroup$ Yeah, the cable was changed. So far I’m at 3 thermosters, two of which were the gulf coast robotics thermosters and the last one being a glass bead thermoster. $\endgroup$ Aug 7 at 14:32
0
$\begingroup$

I've had this problem on a Prusa MK2s. The print was always at the center of the build plate and that's the location (underneath) of the thermistor. The part was small, the cooling fan was chilling the bed at the same time it was trying to maintain temperature. Moving the part a few centimeters away from the center resolved the problem.

In the case of this PEI coated bed, always centering the print caused the PEI to wear in that area, requiring replacement. The operators were informed to place the build in random, non-centered locations in the future.

$\endgroup$
3
  • $\begingroup$ I have been assuming (perhaps incorrectly) that this is the extruder temperature and not the bed temperature that is dropping/ acting strangely. But I do agree a issue with the bed temperature could also cause a thermal runaway error. $\endgroup$
    – Kezat
    Aug 8 at 0:38
  • $\begingroup$ Yeah, this is definitely an issue with the extruder. I’ve tried printing different models in different locations, but no matter what I do, I still get the same result. $\endgroup$ Aug 8 at 17:08
  • 1
    $\begingroup$ At the very least, you've eliminated one possible factor. Check your part cooling fan airflow direction, to ensure it's not hitting the hot end. $\endgroup$
    – fred_dot_u
    Aug 8 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.