2
$\begingroup$

I have 2 printers, an Artillery Sidewinder X1 and an Ender 3 that both have BLTouch sensors installed. This post is about the one (BLTouch clone, the probe is a Smart v3.1 sensor) installed on my Ender.

My problem:

I recently upgraded from Creality's original motherboard to the BigTreeTech SKR mini E3 and touchscreen. Once I had plugged everything in, I flashed the latest firmware with edits made only to suit my BLTouch. I am using the Zmin endstop pin rather than the dedicated BLTouch pin and I double-checked both my wiring and my firmware to make sure my changes were correct. I powered on the printer and everything worked. I even printed a test calibration cube. I was happy with myself for getting everything to work first go and screwed the lid back over the motherboard.

Upon restarting the printer, I tried homing it and the probe would not deploy, and if I did not switch the power off, the extruder assembly would drill into the bed. Using the 'Deploy', 'Stow', and 'Test' buttons do nothing. Running G29 or tapping the ABL button on the touchscreen will return similar results to pressing home or running G28, where the probe will not deploy (or stow if I manually pull it down - note that it does not go into error mode when I do that) and crash into the bed.

Things I have tried already:

  • Running M420 S1 - returns failed to enable bed leveling, invalid mesh

  • Running M500 and M502 after it to clear EEPROM

  • Double checking that the servo pin is connected to the right socket on the motherboard

  • Swapping the BLTouch out for the one that belongs to my other printer

  • Using a multimeter to check the connection between the BLTouch and the servo pin

  • Enabling BLTOUCH_DELAY 500 and BLTOUCH_FORCE_SW_MODE

  • Flipping the servo connector

  • Using the whole BLTouch connector instead of plugging the Z wires of the BLTouch into the Z endstop port and changing the firmware accordingly.

Wiring Diagram

I used this diagram to wire the sensor:

Wiring diagram for BigTreeTech SKR mini E3 board


So I am just about at my wit's end with these BLTouch (clone) sensors - with 3 separate posts on this forum regarding them, my own posts even showing in the 'Similar questions' box at the time of writing this post, but amongst all the frustration I have experienced, I have learned a great deal along the way, from the core workings of the firmware to the design of the motherboard.

4 months later and I still never solved the problem. It seems likely that is a wiring fault or something wrong with the firmware but I have checked the wiring countless times with a multimeter, testing the BLTouch with another printer and using pre-compiled firmware sent to me by BTT support. I am writing to BTT to see if I can get a replacement board but if you have any other ideas I would love to try them.

$\endgroup$
5
  • 1
    $\begingroup$ Why are you're using the Zmin endstop when you have a "dedicated BLTouch" pin? Did the pin designed for this not work? $\endgroup$
    – Kezat
    Aug 9 '21 at 9:06
  • $\begingroup$ You are right, I could use that pin but I would need to crimp a Molex connector to make it fit and nothing gets lost when using the Zmin pin so I may as well save my self the effort of crimping a new connector. Maybe I will though if I pass my local Jaycar to pick up a Molex connector. $\endgroup$
    – HotGlue
    Aug 9 '21 at 10:13
  • 1
    $\begingroup$ Can you add information to your question on exactly how you wired all 5 wires of your BLTouch to your board. $\endgroup$
    – Kezat
    Aug 9 '21 at 21:11
  • 1
    $\begingroup$ Is this a genuine BLTouch from Antclabs or a clone version? If it's a clone, it is possible the pinouts are not the same. $\endgroup$
    – craftxbox
    Aug 11 '21 at 15:25
  • $\begingroup$ It's a clone, but I'm pretty sure the pinout is right. I will double check. What is weird though is that it was working before on the BTT board. I did not do anything with to the wiring or firmware when it stopped working. I have checked all cables as best as I can with as multimetre and the BLTouch does not work with the lid open either. $\endgroup$
    – HotGlue
    Aug 12 '21 at 10:37
0
$\begingroup$

You have written in the comments that

I did not do anything with to the wiring or firmware when it stopped working

And that you tried

Swapping the BLTouch out for the one that belongs to my other printer

And

testing the BLTouch with another printer

It seems from these statements that the answer to your question is: something got damaged in the SKR board. Replacement is probably the only way.

There are however some home made optical/servo proves you can use instead of the BLTouch. They deploy a pin via a servo and use optical endstop for detection. They are reliable and require minimum wiring so that you can reuse the damaged SKR.

You can also try the quickdraw probe by Annex Engineering.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.