4
$\begingroup$

I am having extreme extrusion problems with my Ender 5. I had nearly perfect quality since I got it about 2 years ago but recently I replaced the board with a Creality 4.2.7 Silent Board and I'm having some problems. I've calibrated the E-steps to where is consistently extrudes 100 mm but what should be a 20x20x20 mm cube is 20x20x10 mm (as shown in the picture). Since I haven't really had experience with this sort of problem yet, I have no idea how to fix it.

half height print cube

$\endgroup$
7
$\begingroup$

If the image is suppose to be a 20 mm calibration Cube when it comes out half the height, your problem is the steps per millimeter of the Z-axis, not the extruder. The object you printer is half the height it is supposed to be, so the bed isn't lowering enough and requires more steps. You should double the current value. If the bed doesn't lower enough per layer, the layer advances only half the value it should be while the extruder isn't aware of this half layer height and deposits the normal amount of filament looking as if it over-extrudes per layer. This does look as if there is something wrong with the extruder, but in fact this is caused by the Z-axis movement.

With M92 you can get and set the correct value:

Get the current steps-per-unit settings using M92 with no parameters or M503 on older versions of Marlin.

If the Z-axis has 400 steps/mm in your current setup, you should use 800 steps/mm instead. Note, the steps per millimeter value depends on the driver's and the micro-stepping setting. You need to work that out if you change your board (driver type and micro-stepping jumper or software setting).

$\endgroup$
2
  • 1
    $\begingroup$ I guess the new firmware I put on had 400 steps/mm has a default while is should've been 800 steps/mm. Thanks! $\endgroup$
    – Carter
    Aug 21 at 21:33
  • 4
    $\begingroup$ The value depends on the driver's and the microstepping setting. You need to work that out if you change your board. You're welcome! Thanking is done by voting and accepting answers. $\endgroup$
    – 0scar
    Aug 21 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.