My shiny new Ender 3 V2 seems to ignore the Z-axis limit switch, when I print a model. It moves the nozzle so far down, that it scratches on the bed and destroys the nozzle.

However, when I use the Auto Home function it lowers the nozzle until the limit switch clicks and than stops.

After disabling the stepper motors, the printing platform can be leveled. When after that a printing process is started, Z-axis comes down, the limit switch clicks, but the Z-axis goes about 1.5 mm further down ignoring the switch.

As a result, the nozzle is pressed with such force to the platform that no filament comes out of the nozzle and is grated with such force that the nozzle and the platform get damaged.

I checked the Z-axis offset in the software to be zero. I moved the Z-axis limit switch higher, to check if the behavior changes without success. The installed firmware version is 1.0.2.

Can someone tell me why it ignores the Z-axis limit switch during printing, when it reacts to it during the leveling process? I just want to print my first ever model.

  • $\begingroup$ Do you have a Z-offset limit active in your firmware? Be sure that when leveling the bed with inactive steppers, you need to make sure you home Z once in a while (when moving the head and bef by hand it is easy for the head to come down/up). $\endgroup$
    – 0scar
    Sep 13, 2021 at 22:33
  • $\begingroup$ Has it ever worked ? Could be the switch is not activating so never being seen ? Test the switch in isolation using a multimeter with a continuity mode, or a small battery and a suitable light bulb. $\endgroup$
    – Criggie
    Oct 2, 2021 at 10:25

1 Answer 1


I finally found the problem. The threaded rod of the Z axis was not mounted tight enough to the motor. This resulted in the slipping of the Z axis by large accelerations of the motor.

So... tightening the threaded rod connector socket and redoing the leveling solved the problem.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .