2
$\begingroup$

The Klipper documentation describes how I should apply skew correction:

  1. Print the test model (I printed this 100x100x100 3-dimensional model)
  2. Make the measurements (I have got about 0.5...0.6 mm errors at all of the axes)
  3. Send skew correction G-code at the beginning of the print

This does not look like the most convenient way for me. I'd like to add these values to the Klipper configuration file to make all my prints more straight. However, I did not get the idea of how to edit printer.cfg file properly.

I'm aware of the possibility of going beyond the printing zone. I suppose that for my case (only half a millimeter on a 100 mm model) can not lead to any issues with my printer mechanics.

In the documentation, this part is not adding any details.

Can someone post some examples or short instructions to make this possible?

If you need this information: I have the original Ender 3 (3 y.o. or so) with no kinematics or electronics improvements. Only head modification: V6 with BMG direct extruder.

UPDATE

I tried to append the following to printer.cfg file:

enter image description here

However after restart I see error message:

enter image description here

$\endgroup$
2
  • 1
    $\begingroup$ Is it even worth to correct for 0.5 mm over 100 mm? it's half percent and it could be even caused by measurement errors. $\endgroup$
    – FarO
    Sep 14, 2021 at 19:14
  • 1
    $\begingroup$ @FarO, I'm printing now two relatively large parts (200 mm in height) which should connect to each other. After I printed them in different orientations (I needed to orient them in this way) and the missalignment is clearly visible. So I try to fix this now. $\endgroup$ Sep 14, 2021 at 19:37

1 Answer 1

2
$\begingroup$

You need to enable skew correction in the printer.cfg

[skew_correction]

You need to enter your skew numbers into the console and save it. This will save your skew profile to the bottom of printer.cfg.

SET_SKEW XY=141.22,141.15,100 XZ=140.87,141.34,99.84 YZ=141.12,141.26,99.94
SKEW_PROFILE SAVE=my_skew

Also, Klipper docs warns about skew correction causing problems: https://www.klipper3d.org/Skew_Correction.html#caveats

You need to add SKEW_PROFILE LOAD to your START_PRINT macro and SET_SKEW CLEAR=1 to your END_PRINT macro. You can either add this to your macros in Klipper or slicer program.

My skew parameters may be different from yours. I recommend you to perform your own measurements. My printer is an Ender3 S1 with linear rails.

START_PRINT macro. Skew profile is loaded before the print starts.

SKEW_PROFILE LOAD=<your_skew_profile_name>

start_print macro

END_PRINT macro. Skew profile is disabled before the print is presented.

SET_SKEW CLEAR=1

end_print macro

$\endgroup$
1
  • 2
    $\begingroup$ It would be helpful (and searchable) if the 'code' was actual text instead of screenshots. Please use the Edit feature to improve your answer. $\endgroup$
    – agarza
    Mar 28, 2023 at 2:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .