3
$\begingroup$

Alright, long story but I want to provide as much detail as possible:

I have a heavily modded Ender 3 Pro. Mods include:

  • Metal Extruder
  • Capricorn PTFE tube
  • Glass bed with improved leveling nuts
  • BLTouch
  • LED strip
  • Dual Z-axis motors with the recent addition of BTT E3 RRF control board (and IDEX module so that it could do G34 auto-align) (most recent additions)

I'm using Overture Brand white PLA and for the first print that messed up (pic below), I was using the default "generic PLA" Cura settings for an Ender 3 pro.

The problem:

Anyhow, it caused this kind of print:

3D benchy with printing errors

There are a few angles where it actually looks pretty good. The hull is fairly smooth, the first layer went down well, the roofs and bridging look tolerable, but as you can see, especially around the "pillars" it looks I don't know... under-extruded? Like the lines don't connect very strongly. In fact, it might be hard to tell from this photo but the bottom actually ripped off when I took it off the plate, mostly due to weak connections between each layer.

What I've tried:

I pretty much went step by step through Teaching Tech's calibration guide.

  • I started by getting out my bubble level and 90-degree gauge and just making sure the frame/bed/everything was level and perpendicular to each other and everything.
  • I did the E-steps calibration until I reliably got 100 mm when I asked for 100 mm
  • My first layer had never been a problem (especially with BLTouch and glass bed), so I skipped that step.
  • I did the baseline print. My first one looked like the top of the cube had some under extrusion (you can see through it if you look closely in this photo enter image description here
  • I did the slicer flow calibration and actually it came out a little tiny bit too big (which would indicate I need to turn down the flow), but as Teaching Tech mentioned at the bottom of the page, you can't always trust that so I didn't end up making any changes to flow.
    • Worth pointing out, in this photo of the Slicer Flow calibration cube, you can see some weird holes where the nozzle would be kinda late starting a line. enter image description here
  • The stepper motor driver current thing confuses me but I had previously set the current of both Z-axis' to the values I've seen in several YouTube videos, including Aurora.tech's channel where she covered the same BTT IDEX board and dual Z's.
  • I did the temperature tuning and it seems like for this PLA 210 °C seems to work well.
  • At this point I felt like retraction tuning was the problem and would fix everything, but with the default speeds in Teaching Tech's sample print, distances from 0-8 mm didn't seem to do anything differently in this print: enter image description here
  • I never ended up doing the acceleration tuning
  • For the linear advance, I changed the k value to 0.4
  • I don't have a dial gauge to do the XYZ steps calibration

Long story short, with those few changes I redid the calibration cube and the benchy and they look maybe 5% better but still weird.

My Z-axis squeaks sometimes when moving through a spot 5-10 mm off the bed, so I lubricated them according to the guide here, but I did that prior to that second benchy so it didn't seem to solve it.

After I first posted this, I decided to dive deeper into that squeaky Z-axis. I triple, super-duper checked that both Z threaded rods were parallel to each other and neither was warped/curved/etc... They seem fine. I lubricated them both a bit more and using G-code told the printer to jog the Z-axis up and down the length of the rods about 20ish times. The squeak did eventually go away so I printed another benchy. No dice. Still looks bad.

Per Criggie's answer, I disabled the steppers and moved the axes around to see if they moved smoothly. Both X and Y move great with steppers disabled and then are pretty firm normally. Z is pretty stiff no matter what but that may be intentional. I previously had problems with my Z-axis falling down when prints were over so I installed anti-backlash nuts and with two anti-backlash nuts (one on each rod) I'm not surprised it doesn't want to fall. But again, when I just tell it to move, it moves very smoothly. For instance, I just got out my micrometer and measured the Z movement. I told it to move 100 mm up using OctoPrint and measured the actual movement. Seemed to be 100 on the dot.

I have a BTT filament sensor in the filament path prior to the extruder. I noticed it provided a little friction and I was concerned it was making it hard for the extruder to pull the filament. I removed it, but no improvement in print quality.

One other strange thing I've noticed is the benchy always looks bad in the same spot (the pillars). Makes me wonder WHY it's always that exact spot, not randomly all over.

It's got to have something to do with under-extrusion or flow. I think I ruled out the Z-axis. I made a "tall" benchy by modifying the benchy file to have a platform underneath it. This bumped it up a few cm and the problem still happened in the same spot on the pillars of the benchy (which is now in a completely different spot on the Z. Also, given the "flow" preview in Cura: enter image description here

That circled low flow area is where it always messes up.

So now to figure out why it's got low flow. Again, I calibrated the E-steps and it seems to be accurate. I've also printed benchy's where I told Cura to have 110% flow just to check. The last one I attempted didn't just fail, it failed big time and became a blob at that same spot.

I wonder if the extruder gear is worn and slipping and/or the Capricorn PTFE tube is too restrictive for the "budget" filament brand I'm using that might have trouble sliding through it. I have replacement steel extruder gears showing up Tuesday, will update my question then.

$\endgroup$
9
  • 2
    $\begingroup$ Next time forget the bubble level! ;-) Level the printer to the printer axes, not to gravity! You clearly have an under-extrusion problem, I wonder how the 100 mm is being determined. If in free air, this may be quite different from "at height" which might add more backpressure causing you extruder to skip. $\endgroup$
    – 0scar
    Nov 22, 2021 at 18:44
  • 2
    $\begingroup$ When the nozzle is close to the bed when extruding, there is backpressure from squeezing the filament into the set height (layer height + initial gap). This can cause a different length than 100 mm, but it should not, it means that the filament/extruder is skipping. You clearly are under-extruding, you need to fix that. Could be that your retraction is also not optimal, but you have looked into that. How did you determine the LA value? $\endgroup$
    – 0scar
    Nov 22, 2021 at 19:22
  • 1
    $\begingroup$ Excessive force of the filament from the spool (entangled, high friction, etc.) also causes under-extrusion. You really need to focus on the filament and the extruder, the Bowden tube, everything between the nozzle and where the spool is located. $\endgroup$
    – 0scar
    Nov 23, 2021 at 15:28
  • 1
    $\begingroup$ Need to highlight @0scar 's "retraction is not optimal" idea again. The Cura defaults are for a bowden printer, something like 6.5 mm. If you have a direct hot end that will be waaaaay too much. You usually want it closer to 1.5 mm. $\endgroup$ Nov 23, 2021 at 17:56
  • 1
    $\begingroup$ If this is your reference for a calibration cube, please read my comment. You're spot on with the cube makers ;-) , but as in that comment, that image is not correct. What strikes me is the re-occurring pattern like it is in sync with the threaded rods pitch? Maybe you could decouple the spool and feed the extruder a pre-cut length + 1 m of what you would need for the cube, print the cube and measure what is left minus 1 m and compare that to the calculated by the slicer. $\endgroup$
    – 0scar
    Nov 24, 2021 at 9:09

2 Answers 2

1
$\begingroup$

enter image description here It was a worn extruder gear. I didn’t think it was THAT worn, and when I loosened it a bit and slid it a few mm so that the gear hit the filament in a fresh spot it didn’t improve. But new stainless steel gears showed up today and when I installed one it worked perfect. Same file/settings/gcode that had failed several times previously when testing other things

$\endgroup$
1
  • 1
    $\begingroup$ Thanks for coming back and posting the answer to your own question! Good to find the extruder gear was the problem, I did not know that it would cause this behavior, but in hindsight logical. Thanks for teaching me! $\endgroup$
    – 0scar
    Nov 30, 2021 at 17:48
0
$\begingroup$

I see positional errors in X and Y, but Z looks okay.

That suggests one or both of your belts is stretched, perhaps damaged, or maybe just loose.

Try engaging the stepper motors in the device's panel and push the head left/right or pull the bed toward/away from you. They should both resist handforce, and you then feel like it needs to be pushed with full arm/shoulder force to move it (but don't actually force anything with that level !!)

There should be none/almost no play in X or Y with the steppers locked/engaged.

Then disable the stepper motors in the same menu, and both bed and head should slide with one finger's push.

This test does not work for Z but that axis seems fine in your benchy print.

Also check the condition of the drive/tension pulleys at either end of the belts. There should be no powdered plastic from the cogs, nor rubbery bits from the belt.

I cannot see any over/under extrusion, so the extruder/drive is probably okay.

$\endgroup$
2
  • 1
    $\begingroup$ Thank you. I'll triple check all this tonight when I get home. That being said, I had disabled the steppers and moved everything around earlier in the evening before posting that question (not to check anything, just happened to) and it seemed to have fluid movement. I'll purposefully examine it later. Also worth pointing out I edited the question to fix some of the photo links. $\endgroup$ Nov 22, 2021 at 18:25
  • $\begingroup$ Updated notes about your answer in my question $\endgroup$ Nov 23, 2021 at 14:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .