1
$\begingroup$

I'm trying to install a BLTouch probe. I have an Ender 3 Pro with 4.2.2 board and I’m trying to connect a BLTouch 3.1 to it. I've bought a generic (but authentic) BLTouch instead of a Creality kit. I've plugged the 3-pin connector into the correct slots on the board (didn't have to rewire, pins seem to be in correct order), but I'm trying to connect the 2-pin connector to the Z-stop connector.

Wiring seems to be in order (although I'm not an expert), when I turn on the printer, the BLTouch flashes and deploys twice but when I try to autohome or level or deploy it through options, menu probe autohomes X and Y axis, but when it comes to the Z axis, the probe doesn’t deploy and hotend simply crashes into the bed.

I've followed this video when I was compiling firmware (I tried both the normal Marlin build and the nightly release).

My configuration files can be found here. If someone would be willing to take a look.

E.g. from my configuration (Configuration.h) file:

/**
 * Enable this option for a probe connected to the Z-MIN pin.
 * The probe replaces the Z-MIN endstop and is used for Z homing.
 * (Automatically enables USE_PROBE_FOR_Z_HOMING.)
 */
//#define Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN

// Force the use of the probe for Z-axis homing
#define USE_PROBE_FOR_Z_HOMING

My guess is that I have to force the firmware to somehow recognize the correct signal pin, but then again, I'm out of my depth. I've seen this exact problem mentioned in many places all over the internet but never with a solution attached.

$\endgroup$

1 Answer 1

2
$\begingroup$

Are you using Creality's pre-built software?

In that case, you must connect the two pins to the BLTouch port. Altogether, you would have all five wires connected there.

Are you using your own Marlin build?

In that case, you must uncomment #define Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN in order to plug in those two wires into the Z end stop connector. Otherwise, you need to use the BLTouch port as mentioned above.

$\endgroup$
2
  • $\begingroup$ Very good spot! I've inserted the code of the OP in the question, you see that this is exactly the problem! Welcome to 3DPrinting.SE! P.S. Please don't forget to vote on questions/answer, voting drives the community! $\endgroup$
    – 0scar
    Commented Dec 20, 2021 at 8:55
  • $\begingroup$ I've tried a couple more times but there is no improvement. I'm going to buy a 5pin connector and try to connect the probe to the default 5pin socket and see if it works with prepackaged creality firmware. If it does I will try to compile on my own again. I will have to do my own build anyway because I want advanced park features enabled (need to embed magnets easily). $\endgroup$ Commented Dec 20, 2021 at 17:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .