-1
$\begingroup$

Everything was working perfectly until I installed the BLTouch. After installing it every time I print it makes a loud knocking/clicking sound. Does anyone know how to fix this? I am using a Neptune 2 a clone of an Ender 3 with Marlin firmware.

$\endgroup$
5
  • $\begingroup$ Can you describe more when the knock happens? Is it all the time or only when the printhead is moving? Is it X+Y or just X or just Y? If you jog the printer around from the control panel, does it make the same noise? $\endgroup$
    – Criggie
    Dec 20, 2021 at 0:51
  • $\begingroup$ If you unload the filament and print normally, does it make the noise? Does the noise go away as your Z increases ? Has the quality of your printing changed/dropped since the addition? $\endgroup$
    – Criggie
    Dec 20, 2021 at 0:52
  • 1
    $\begingroup$ Your second "sock puppet" account has been suspended for plagiarism. If you wish to have the two accounts merged, then please notify one of the moderators. $\endgroup$
    – Greenonline
    Jan 1 at 12:45
  • 2
    $\begingroup$ Found the origin of the second sock puppet answer: github.com/escknx/Creative3D-Elf-Binaries/blob/master/… $\endgroup$
    – Trish
    Jan 1 at 17:47
  • $\begingroup$ @Trish - Well done, I've edited and added the URL to my comment under the second sock answer. $\endgroup$
    – Greenonline
    Jan 3 at 14:29

1 Answer 1

1
$\begingroup$

The most probable reason is that your Z offset is too small, the nozzle is too close to the build plate, when molten filament has too much friction to flow out of the nozzle, the back pressure causes the extruder to skip back making loud thumping/knocking sounds. You could increase the Z offset for instance or redefine the bed height with G92.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .