-1
$\begingroup$

I purchased a new 4.2.7 (256k) board for my Ender 5 Pro and added the CR Touch. I got everything connected and flashed the board with the "Ender-5 Pro- Marlin2.0.1 - V1.1.1 - ALT - TMC2235.bin" firmware from the creality.com/download > Accessory Firmware > CR Touch Firmware for 32-bit Motherboard > Ender-5 Pro.zip

Problem:

When told to Auto Home the Z-axis drops 5 mm then checks X-axis & Y-axis endstops = OK

But then the Z-axis drops another 3 mm and the CR Touch deploys > Retracts > deploys > Retracts and Faults out.

The instructions say to move the Z-axis to get the offset but it will only go down while the CR Touch is faulted (Stopped)

I've checked all wiring made sure the Z-axis endstop was disconnected. No help.

Thinking it was a board issue I wanted to check the normal, no CR Touch, functionality, so I flashed the Marlin2.0.1 V1.0.1 original versionTMC2225 "Marlin2.0.1 - V1.0.1 - Endstop - TMC2225.bin" firmware onto the board, and reconnected the Z-axis endstop. The printer worked like normal.

Not wanting to fail, I decided to try another firmware, so I decided to use TH3D_Unified2_CrealityV4X_256K. I went through and set up everything using CUSTOM_PROBE settings. And wouldn't you know it... SAME Results as with the Creality "Ender-5 Pro- Marlin2.0.1 - V1.1.1 - ALT - TMC2235.bin" firmware.

Bed drops 5 mm at the start of Auto Home then drops another 3 mm after centering to deploy the CR Touch. The CR Touch deploys > Retracts > deploys > Retracts then Faults out. At no point does the bed ever try to go up.

The only other thing I can think of is that the CR Touch isn't working right. I thought it was supposed to deploy then the bed was to come up to it to detect it. Could the wiring "harness" for the CR Touch be incorrectly wired? (Wiring below)

Can someone help me with this one? Do I have a bad Board? Do I have a bad CR Touch? Or am I just not getting a setting right somewhere?


CR Touch Wiring (Current) 5pin from factory --- Connectors can only be put in one way

@ Creality 4.2.7 Board --- From Left to Right

G = White | V = Black | IN = Yellow | G = Red | Out = Blue

@ Creality CR Touch --- From Left to Right with Creality logo facing you

Blue | Red | Yellow | Black | White

$\endgroup$
3
  • $\begingroup$ Did you ever get a suitable firmware working with this configuration? I have an ender 5 pro - upgraded the mainboard to a 4.2.7, added a genuine Creality CR leveller and filament runout sensor. I cant get a Firmware from anywhere that seems to work with this set up. $\endgroup$
    – Paul M
    Dec 12, 2022 at 11:10
  • $\begingroup$ No help here but to confirm that on my Ender 3 Max (4.2.2 board) with a new CR Touch, the sensor lights up and responds to Deploy/Stow test commands. When I execute Auto Home, it does descend to find the bed position but does so with the probe retracted, and if I let it continue would crash into the bed. $\endgroup$
    – Dennis H
    Dec 25, 2022 at 22:19
  • $\begingroup$ A friend of mine has this exact same setup and this exact same problem. Have you guys found any solution yet by any chance? $\endgroup$ Mar 4, 2023 at 7:19

3 Answers 3

0
$\begingroup$

What you describe is very common behavior for a faulty sensor or bad wiring. I've had my fair share of knock-off BLTouch clones that show this exact behavior. When replaced by a genuine BLTouch sensor, the issues where gone. You might have gotten a defective sensor. You should write the vendor that it doesn't work and ask for a replacement.

$\endgroup$
0
$\begingroup$

Make sure that you’ve changed the G-code in your slicer so that it uses the auto leveling. I forgot to do that when I installed a CR Touch on my Ender 3 and the behavior was similar to what you describe: the printer would deploy the CR Touch a couple times, and then just stop.

Adding a G29 instruction to the G-code in Cura’s printer configuration (I put it after the G28 instruction) will tell the printer to use the auto bed leveling. Once I did that, the printer started working as expected.

$\endgroup$
-1
$\begingroup$

Comment this line: Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN (comment=// before the line). So you search for this line in the config file, comment it in order to disable it.

2nd step, uncomment: Z_MIN_PROBE_ENDSTOP so delete the // in front of the line.

$\endgroup$
1
  • 2
    $\begingroup$ As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center. $\endgroup$
    – Community Bot
    Aug 17, 2022 at 21:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .