1
$\begingroup$

I am trying to fix my Ender 3 printer at work. Someone else had it before me and added a direct drive extruder, auto bed leveling, and changed the firmware. He claimed it worked fine, however when I started a print the nozzle was clogged beyond belief so it would not print.

I changed nozzles and had to clean up the heating block a little bit. Once I reassembled the printer and booted it up it shows the error message of Thermal Runaway for extruder 1 and tells me to reset it. I tried powering it off and back on to "reset" it but that did nothing. Within about 10 seconds of turning the printer on the error message shows up and it starts beeping obnoxiously.

Is this caused by something wrong with the thermistor? Everything I have read so far says to check for a faulty thermistor and see if the room temperature reading is 0 °C. However, I cannot do that because it gives the error instantly and will not leave that screen.

$\endgroup$
7
  • $\begingroup$ Why not return it? $\endgroup$
    – Kilisi
    Jun 10 at 13:26
  • $\begingroup$ I can't return it. The person who was formerly in charge of it got pulled off the project because he was not getting enough done, so now I inherited it and have to get it running properly again. We have owned the printer for quite a while. It worked great when it showed up in it's un-modified form. Now that he added all of these extra things we cannot figure out how to get it to work, and getting rid of the thermal runaway code seems to be the first step in getting it working again' $\endgroup$
    – BBartter
    Jun 10 at 16:47
  • $\begingroup$ Why not return it to stock condition? Perhaps just flashing the firmware might solve the problem $\endgroup$
    – Kilisi
    Jun 10 at 17:09
  • $\begingroup$ Will try that and report back. My boss is worried that he has it so messed up we can't return it. Not sure we have to parts to revert it back to bowden extruder though. Does direct drive change the firmware required? or can direct drive run on the original firmware? It is just the stock extruder mounted over the hotend. $\endgroup$
    – BBartter
    Jun 10 at 18:05
  • $\begingroup$ For the price of an Ender 3 I'd be tempted to write it off and keep it for parts and buy a new one. Troubleshooting may cost more than the replacement. $\endgroup$
    – Kilisi
    Jun 10 at 22:04

1 Answer 1

0
$\begingroup$

I've found a single reference of the same issue you are experiencing. That Ender 3 also showed the thermal runaway error on startup.

This was caused by a hotend thermistor that was shorted out, replacing the thermistor solved the issue.

Quoting the reference, context:

I installed a new Micro-Swiss hot end.Did a few prints with it, works great!When I wanted to do another one, the printer made a loud beeping noise, and gave a Thermal Runaway at E1 error at startup.

Solution:

For people stumbling across this in the future, my issue was resolved by a shorted thermistor. After changing it to another one, the printer worked fine and gives a temp readout.

$\endgroup$
1
  • $\begingroup$ Thanks, got a new thermistor on the way, will report back wit how it turns out. $\endgroup$
    – BBartter
    Jun 13 at 12:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .