2
$\begingroup$

I have an Artillery Hornet printer that I am very satisfied with. I make my models in Blender, export them as STL files, and import them into Cura slicer. Everything works great with no problems, mostly. But yesterday, I made a model that I used a reference image in Blender (deleted it before exporting then). And when I printed it, direct afterward, the printer unloads the filament. I tried to print it multiple times and every time it did the same. No big problem then, but a bit annoying.

Does anyone have any idea what could cause this, and how to prevent it? Other models I make in Blender have not given me that result then. I still have not tried making other models with a reference image to compare the result. So I found this place first and try to ask if someone knows about that problem.

This is the end G-code:

G1 E-6 F9000
M104 S0 T0 ; turn off temperature
M140 S0 ; turn off bed
G1 X110 Y220 F10000
M84 ; disable motors
$\endgroup$
5
  • $\begingroup$ Can you share a link to the G-code, e.g. posted on PasteBin.com? $\endgroup$
    – 0scar
    Aug 2 at 13:41
  • $\begingroup$ Can you clarify what you mean by "unloads"? Does it just back out slightly, or eject the filament entirely so it's hanging loose? $\endgroup$ Aug 2 at 15:04
  • $\begingroup$ The problem was solved by the answer from Peter K. I just disabled the part of end code. It rejected the filament entirely after printing. Not all models, but 1 i made. So i still wonder if disable that part of code, got any negative impact on printing other models. So far it works perfect then. $\endgroup$
    – mathias
    Aug 2 at 16:33
  • $\begingroup$ @mathias Nice that the answer solved it for you, please accept the answer by selecting the tick mark. Our community is built on reputation, please acknowledge the time and effort that is taken to produce the answer. Voting is key! Thanks! P.S. please add the final lines of G-code from the file into your question. $\endgroup$
    – 0scar
    Aug 3 at 7:58
  • 1
    $\begingroup$ Thanks. Just edited it and added the original end G-code $\endgroup$
    – mathias
    Aug 3 at 13:24

1 Answer 1

3
$\begingroup$

I haven't used your printer type, but this link suggests:

If your printer unloads the filament after each printing session automatically, you might want to check the end code of your machine and disable the retraction (;G1 E-6 F9000).

$\endgroup$
8
  • $\begingroup$ Thanks allot for that info, i will try it. Even though it not unload filament for other models i made. I just wonder if i disable it, will it have any negative impact on something? what is the purpose with that code line? $\endgroup$
    – mathias
    Aug 2 at 15:01
  • 2
    $\begingroup$ I bet the problem is that this was supposed to be a relative move of -6 mm (retract just enough to prevent oozing while cooling down) but the extruder was in absolute mode and it went back to a position of -6 relative to where it was at the start of the print. Instead of removing that line, put M83 on a line before it and M82 on a line after it so it's a relative move. $\endgroup$ Aug 2 at 16:58
  • 1
    $\begingroup$ Thanks allot for that info. Me totaly new to gcode, but i will try this. It worked fine then with just disable that line, but might effect other things i guess then? will try your advice. Thanks! $\endgroup$
    – mathias
    Aug 2 at 17:38
  • $\begingroup$ @R..GitHubSTOPHELPINGICE I've asked the OP to paste some lines of G-code in the question, I hope that the relative/absolute option is evident from the G-code. It remains a mystery why that only is happening for that specific model. $\endgroup$
    – 0scar
    Aug 3 at 8:00
  • 1
    $\begingroup$ @R..GitHubSTOPHELPINGICE As seen from the updated question, it still is in absolute mode, good spot! Depending on when the last reset was, -6 can take you far. It is worth to add an additional answer pointing to the absolute/relative extrusion as the end G-code is incorrect, disabling the retraction in the end code is just a quick fix. $\endgroup$
    – 0scar
    Aug 3 at 17:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .