I upgraded my Ender 3 Pro from the stock 8-bit motherboard to a new 32-bit 4.2.7 motherboard. No problems were encountered with the swap, flashing of the new firmware, or calibration.

When I went to start the first test print, the firmware throws the E1 Error: "Heating Failed: E1; PRINTER HALTED; Please Reset".

When the print started, the bed heated up to the requested 60 °C, and then started warming the print head to 210 °C. Once the print head reached 205 °C, the temperature started to drop. It dropped back down to 200 °C, then up to 202 °C then down to 198 °C and so on. It kept doing the up and down heating until it dropped to 190 °C at which point the E1 error was displayed. I have run through the cycle several times with different prints, and through the menu options; and it always fails in the same up and down way.

Printer Specs:

  • Ender 3 Pro
  • Upgraded motherboard 4.2.7 (silent stepper drivers)
  • Matching upgrade of Marlin to version 2.0.6 (downloaded from Creality)
  • BLTouch
  • PEI print bed
  • Replacement bed springs
  • everything else is stock

Prior to the upgrade, everything worked fine. I printed several small prints the day before without a problem. After the upgrade the E1 error.

Thoughts? Suggestions?

  • $\begingroup$ Sounds like thermal runaway protection kicked in, and the PID needs to be tuned. This guide will help you do the PID autotuning teachingtechyt.github.io/calibration.html#pid $\endgroup$
    – F.Ahmed
    Aug 7, 2022 at 16:30
  • $\begingroup$ Yes, it turned out to need PID Calibration. I am composing an answer with the details. $\endgroup$
    – codingCat
    Aug 8, 2022 at 1:00

1 Answer 1


Problem Solved

After checking in with the Ender 3 group on Facebook and doing quite a bit more research I tracked the problem down to PID calibration. The default settings for the board were not heating the print head properly. Because it was coming in short, the thermal runaway logic on the new board cut in and shut everything down.

To fix the problem, the printer needs to run a PID autotune. This is a good idea when you replace any part between the nozzle and the logic board. To accomplish the autotune you need to access the printers console through an app such as Pronterface. You should also take care when hooking in a USB cable to the printer. The 4.2.7 board runs power to the USB port. To get the printer connected to your computer, you will need to mask off the power pin on the USB cable (with the possibility of blowing the chip on the board if you skip this step)

The Marlin command for PID autotune is M303. Follow this up with an M301 to set the results from the autotune. And don't forget to finish up with an M500 to save the settings to the EEPROM.

I would suggest this video from Teaching Tech for an example of the process, and this video from 3D Print General to conduct the same autotune on the build plate.

Post Script

Important Safety Tip - The 4.2.7 board draws more power than the old 8 bit board. During my first test print after the PID calibration, the connector between the power supply and the motherboard melted down. It seems that the wires were crimped rather than soldered. This was fine with the old board, but it was too much with the added power draw. The poor connection caused the wires in the connection to over heat. This is a fire hazard.

Check the power connector. remove the shrink wrap and take a close look. If you don't see solder on the joint, replace it. It is worth the slight expense and hassle to avoid ruining your printer and potentially starting a fire.

The issues is discussed in this Makers Muse video.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .