0
$\begingroup$

I have an Ender 3 Pro with the direct drive upgrade, aluminum extruder (The same problem happened with the plastic one), double-sided bed default black on one side and PEI on the other (Happens with both), aluminum adjustment knobs for bed with better springs, and upgraded spool holder with ball bearings.

Things I have done to try to fix this:

  • Add aluminum extruder
  • Upgraded spool holder with ball bearings
  • Calibrated my E-steps
  • Upgraded firmware
  • Stopped using OctoPi
  • Switched build surface (The only one that I could try that I have on hand is glass but that didn't work the last time I tried it)
  • Tightened belts
  • Printed calibration cube
  • Printed temp tower
  • Printed retraction tower
  • Printed retraction speed tower
  • Looked up YouTube videos
  • Cleaned motherboard (There was dust in there)

Those all failed and I have no idea what this is or how to get rid of it, please help.

Settings:

  • Layer height: 0.2 mm (I haven't tried a different layer height)
  • Print speed: 40 mm/s (I have tried slower/faster)
  • Nozzle temperature: 195 °C (I have tried higher)
  • Infill density: 15 % pattern: cubic (I have tried different infill patterns and density)
  • Cooling: 100 %

I'm afraid there is literally nothing else I could possibly do at this point except replace/tune mechanical parts, which I have tried.

Photo of a calibration cube with irregularities on the surfaces

$\endgroup$
8
  • $\begingroup$ UPDATE: I have determined that the problem has something todo with infill. If I change the infill then the problem also changes (Like the pattern on the surface changes) I'm currently trying different infill patterns to see which ones yields the best results. $\endgroup$
    – Adam Salem
    Commented Nov 21, 2022 at 0:42
  • $\begingroup$ What settings do you have on the shell? The shell should always be multiple of the nozzle diameter. Also what nozzle size you're using and which slicer. Depending on the slicer there are some settings that like print shell before infill and infill overlap. $\endgroup$
    – LostKatana
    Commented Nov 21, 2022 at 7:56
  • $\begingroup$ @LostKatana, can you explain what you mean by this? In PrusaSlicer, vertical shells are a quantity, not a distance. On horizontal shells thickness, it should be a multiple of the layer height, not nozzle diameter, right? $\endgroup$
    – LarryBud
    Commented Nov 21, 2022 at 15:28
  • $\begingroup$ I am using Cura Slicer; and did you mean walls? I've tried 2, 3, 4 walls and it still looks the same. $\endgroup$
    – Adam Salem
    Commented Nov 22, 2022 at 0:16
  • $\begingroup$ @LarryBud I'm not familiar with PrusaSlicer, but the shell/wall should be a multiple of the nozzle as e.g. Cura calculates based on the thickness how many (wall line count is the setting name) it needs and will adjust gcode accordingly. $\endgroup$
    – LostKatana
    Commented Nov 22, 2022 at 17:44

1 Answer 1

0
$\begingroup$

I bought a TL smoother which fixed the problem!

$\endgroup$
3
  • 1
    $\begingroup$ It would be beneficial to future readers if you could explain what TL smoothers are and how they fixed the problem. $\endgroup$
    – agarza
    Commented Dec 1, 2022 at 2:05
  • 1
    $\begingroup$ TL smoothers only work for DRV8825 drivers, so the question is, do you have these drivers?, else there might be a different solution, or did you print the exact G-code file. Please expand the answer to include more information. $\endgroup$
    – 0scar
    Commented Dec 1, 2022 at 7:40
  • $\begingroup$ This seems plausible even with the A4988s in a classic Ender. Without reduction gearing, the E motor only has 5.8 full steps per mm of filament moved. 1 mm of filament is about 30 linear mm of extrusion, so you get a full step about every 5 mm of motion. If microstepping linearity is poor (and it's likely to be poor under the high holding torque needs of a direct drive extruder) you'd expect to see this kind of oscillating extrusion. $\endgroup$ Commented Dec 1, 2022 at 14:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .