Recently, I've installed a new BIGTREETECH SKR mini E3 V3.0 board on Creality Ender-5. Previously, I was using SKR mini E3 V1.2 board, but it broke down and I had to replace it. I connected new one exactly like the previous board and calibrated the printer. Everything seemed to be working properly.

Now, I'm getting unexpected M122 errors while printing from OctoPrint:

M122 error on printer's display

This is OctoPrint's console output:

Recv: ok
Recv: Error:checksum mismatch, Last Line: 30869
Recv: Resend: 30870
Should resend line 30870 but no sufficient history is available, can't resend
Changing monitoring state from "Printing" to "Error"
Send: G1 X109.711 Y118.883 E.02691
Send: M112
Send: N31035 M112*37
Send: N31036 M104 T0 S0*38
Send: N31037 M140 S0*99
Changing monitoring state from "Error" to "Offline after error"
Connection closed, closing down monitor
Closing down send loop

This checksum mismatch error appears randomly at different stages of printing, but always around 30000 line.

What is my setup?

  • Creality Ender-5
  • Raspberry Pi 3A+
  • OctoPrint 1.8.6
  • OctoPi 0.18.0
  • SKR mini E3 V3.0 board
  • My custom firmware

I customized the firmware from BIGTREETECH official repository for this board. This problem also occurs, when I upload official firmware for this board. OctoPrint is connected to the board via GPIO pins - that's how it was connected before and I have no way to connect it via USB cable.

What have I done to resolve this issue?

  • Tried printing from SD card. This error doesn't occur, when printing from SD card.
  • Replaced cables connecting the board with Raspberry Pi.
  • Isolated all the electronics away from the printer's case.
  • Changed SD card used by OctoPrint to a new, empty one.
  • Updated OctoPrint to recent, stable version.
  • Uninstalled all unnecessary OctoPrint plugins.
  • Tried flashing official firmware.

I suppose that the problem is in the connection between the printer and OctoPrint. What can cause this error to happen?


1 Answer 1


According to Marlin docs, these checksum mismatch errors were due to the baud rate being set incorrectly.

The serial communication speed of the printer should be as fast as it can manage without generating errors. In most cases 115200 gives a good balance between speed and stability. Start with 250000 and only go lower if “line number” and “checksum” errors start to appear.

Lowering baud rate solved the problem.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .