I’ve recently obtained a Creality Ender-3 V2 3D printer and have tried setting it up. With it came 2 modifications (CR Touch auto bed leveling kit and dual Z-axis kit).

The installation of the dual Z-axis kit was fine, and so was the CR Touch. Before I tried to install firmware for the CR Touch, the printer seemed to do everything fine. On activation, the Creality startup screen appeared with a loading bar. After the bar loaded it gave me the basic options. I was able to check and see that the current firmware version was 1.0.4. Also, during the wiring of the CR Touch kit, I checked the motherboard version, which was version 4.2.2. After it was functioning fine, I decided to install the CR Touch firmware.

When I tried to install the firmware for the first few times into the printer's SD card reader, nothing happened. I then decided to try plugging it into the card reader inside the display. When I booted it up this time, it displayed the Creality startup screen with no download bar, three “0.00” at the bottom which would flash to “???” every second, and a number above those three things which switched from 21 to 22 every second or two. After some time the number stuck at 22. After this, I took the card out of the display and turned the printer off. Since then, the printer has done nothing.

Now when the 3D printer turns on, it’s just the Creality startup screen with no loading bar. It stays on this screen and nothing changes, nothing happens. The printer also does not seem to connect to my computer (USB or Wi-Fi), does not accept anything from the card reader on the front of the machine, and does not accept anything from the card reader inside the display.

Ever since this has begun, I’ve done the following:

  • Inserting the card with many different pieces of firmware into the display card reader and front card reader. Result: Nothing happened.
  • Inserting the card with a .txt file containing M502 M500 (factory reset code and setting save code) and renaming it to .gcode. Result: Nothing happened.
  • Connecting a computer to the printer via a USB cord. Result: Computer detects nothing.
  • Sending M502 and M500 to the printer via Creality Print software. Result: Nothing happened because no printer was found.
  • Checked the file system and partitioning style. Result: FAT32 and MBR.
  • Used Pronterface to try and connect to the printer. Result: Weird error message reading “Update failed, no SD/TF-card or error.” I tried this with and without the SD card in both the display card reader and the front card reader.
  • Have tried Googling many different answers to this issue. Unable to exactly pinpoint anything the problem. I found one Reddit post about the “Update failed, no SD/TF-card or error” error, but it does not have any helpful replies. Result: Nothing helpful.

It’s been 2 days of continuous work on the printer and nothing has come about to signify an end to this suffering besides the “Update failed, no SD/TF-card or error” error. I’m tired of nothing working and unrelated answers, so I’ve decided to ask the question myself.

  • $\begingroup$ What firmware are you trying to flash? $\endgroup$
    – kosteklvp
    Dec 27, 2022 at 6:59
  • $\begingroup$ I have tried flashing: Ender-3 v2 4.2.2mainboard (32bit) and GD-Ender-3 V2-Marlin2.0.8.2-HW-V4.2.2-SW-V1.0.4_E_N_20211230. A bit of additional information, the main board runs on a 32-bit ARM processor. I’ve also tried disconnecting the thermistor from the main board. Nothing happened. $\endgroup$
    – powbrick
    Dec 27, 2022 at 15:56

1 Answer 1


I’ve figured it out. The issue was that the SD card was faulty, even though it seemed to work perfectly fine. I went out and bought a new one and then everything started working again. I tried flashing the firmware I tried before and it worked perfectly. Even the auto leveling works. Thanks for the help but it seems like the answer was again a very weird solution, a very difficult to find solution.

  • 3
    $\begingroup$ Thanks for sharing your solution. Remember to accept your answer. $\endgroup$
    – kosteklvp
    Dec 28, 2022 at 3:21
  • 2
    $\begingroup$ Accepting the answer (pressing the checkmark) in front of the answer is possible after 48 hours of posting! Please take the tour and read help center, hope to see you around posting questions and answers! Thanks for answering your own question! Never would have guessed that the SD card would be the problem! $\endgroup$
    – 0scar
    Dec 28, 2022 at 8:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .