I haven't used my Creality Ender 3 S1 in a week. But I started it now. During auto leveling and auto-home the stepper motor for the build-plate (Y axis?) goes over the limit and a unhealthy sound is heard (the stepper pulley skips the belt).

All worked well last time I used the printer. I have tried to "Disable motors" and manually moved the plate, but it did not fell in "alignment", so the noise will come e.g. with "auto-home" again.

Is there a way I can reset this or may something be broken?

I did "Control -> Reset Configuration" and tried to use "auto-home" again, but the same problem occurred. I also tried to tighten the belt for the motor that moves the build-plate, but it did not help.

It sounds like something is broken. In some way, it sounds like the stepper motor has the "wrong position", if that can happen. Perhaps there are some "encoder" that is broken?

Any suggestions on how to move on from here?

To reproduce my problem:

  1. I disable the stepper motors.
  2. Move the build-plate as close to the motor as possible.
  3. I do "Control -> Reset Configuration" to reset the printer.
  4. I do "auto-home". The end result of this is that the build-plate is centralized and the "level-pin" on the nozzle is in the center of the build plate.
  5. When I do "auto-level" now, it eventually tries to move the build-plate too far away from the motor, so the pulley skips the belt and noise is heard.

Auto home

When looking at this video of Creality Ender 3 S1 doing auto home, it moves the build-plate as close to the motor as possible, before moving the build-plate to home. This does hot happen on mine.

Instead, if I first put the build-plate in the center, then start the auto home. It never moves the build-plate as close to the motor as possible, it only moves the build-plate away and finally the motor pulley skips the belt.


1 Answer 1


When a stepper keeps on spinning and skipping the belt, it usually indicates that there is something wrong with the end stop. If it is not pressed, the stepper will rotate the length of the bed usually making the pulley skip the belt.

Please check your Y-end stop, you find it in the image below left of the stepper (you see the cable of the endstop, just above where the sticker is being pulled off).

enter image description here

You could try and press this switch the moment you auto home to see if it works. If it works, make sure the carriage hits the switch.

The updated question explains that the bed moves in opposite direction when homing, if so, this hints to a defective end stop switch or cable (or unconnected). When the end stop is defective the firmware (when properly configured and proper switch state routing is used) the printer assumes the end stop is triggered and moves away from the end stop.

  • 1
    $\begingroup$ It turns out, that a cable in the area of your photo had been disconnected. When I connected it, both auto-home and auto-leveling worked fine again. Thanks. $\endgroup$
    – Jonas
    Commented Jan 9, 2023 at 23:19
  • $\begingroup$ Happy printing @Jonas! $\endgroup$
    – 0scar
    Commented Jan 9, 2023 at 23:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .